enfr

FAQ - Installation

Question: What are the prerequisites for Code_Aster installation?

Answer: Code_Aster’s command language is written in Python; the tools which can launch a study or an overload with owners development, etc. are written in Tcl.

So you have to install Python and Tcl before installing Code_Aster. Please read the download free software page.

Question: Which compiler version must I use to develop in Code_Aster?

Answer: In general we advise you to use the latest C compilers version and Fortran.

GCC (for GNU Compiler Collection - which integrates the C, C++ compiler and Fortran) is used with Linux.

With Proprietary-Unix we advise you to use the manufacturer’s compiler; you could use gcc but we haven’t tested it yet.

With Windows the Visual Studio compilers are used.

Question: I can’t install a prerequisite - What can I do?

Answer: Read the README or INSTALL files provided.

If you can’t find what you are looking for we advise you to visit the website of the product concerned: you should be able to post your question in their Forum or FAQ section.

Question: the installation of Code_Aster was not successful, where to find help?

Answer: Read carefully the README or INSTALL files provided.

Have you installed all the prerequisites? Ask for help in our Installation forum.