Rechercher dans le site

Code_Aster

Nommage des versions

  • stable : Il s’agit de la version d’exploitation qualifiée par EDF pour ses besoins d’études, et à laquelle fait référence la fiche Qualité. Actuellement, il s’agit de la version 11.6. Elle est mise à jour tous les six mois.
  • stable-updates : Il s’agit des états transitoires entre deux versions stables. Ils intègrent uniquement des corrections d’anomalies à périodicité mensuelle. Cela correspond aux incréments de versions 11.6.x.
  • testing : Il s’agit d’un état figé de la version unstable de développement. Actuellement, il s’agit de la version 12.2. Elle est mise à jour tous les six mois.
  • unstable : Il s’agit de la version qui intègre chaque semaine les nouveaux développements ainsi que des corrections d’anomalies. Cela correspond aux incréments de versions 12.2.x.

Versions disponibles

Nom de version
Archive
Numéro de version
Date
Taille
md5
Code_Aster stable aster-full-src-11.6.0-1.noarch.tar.gz 11.6 11 juin 2014 186 Mo e48db35defbb1e431b8a686b856f4596
Code_Aster testing aster-full-src-12.2.0-1.noarch.tar.gz 12.2 11 juin 2014 185 Mo f72287a9d40bc9064c47d6ba682bb4d5

Les nouvelles versions stabilisées de Code_Aster Open source, Code_Aster stable (11.6) et Code_Aster testing (12.2) sont disponibles en téléchargement.

La version 11.6 est une version corrective de la version 11.4. La version 12.2 intègre des corrections et des évolutions par rapport à celle-ci.

Le format de diffusion reste le même : une unique archive contenant Code_Aster et tous les outils annexes sous forme de code source.

Outre Code_Aster, on retrouve les dernières mises à jour disponibles : astk 1.13.4 (interface graphique de lancement d’Aster), Eficas 7.4.0 (éditeur graphique de fichiers de commandes), Homard 10.6 (outil de raffinement et déraffinement de maillages), la bibliothèque med 3.0.7 (échange de maillages et de champs avec des codes tiers), metis 4.0.3 (outil de renumérotation), mumps 4.10.0 (solveur direct), etc.

Les pré-requis sont :

  • une version récente de Python (2.6 ou 2.7) avec le module numpy,
  • un compilateur fortran,
  • un compilateur C/C++.

Pour l’installation, consultez le fichier README, puis

python setup.py install --prefix=/opt/aster.

Il est conseillé d’utiliser les compilateurs Intel s’ils sont disponibles pour Code_Aster, Mumps et Metis et les compilateurs GNU pour les autres produits embarqués.


Suivre la vie du site RSS 2.0 | Plan du site | Contact | Administration | SPIP