Code_Aster forums

Welcome on the forums. Please post in English or French.

You are not logged in. You won't be able to post until you register and log in using the top-right bar.

#1 2012-07-04 15:50:19

yoursbh
Member
From: INSA Rouen, FRANCE
Registered: 2012-07-04
Posts: 75
Website

[RESOLU] Problème installation Salome-Meca-2010.2

Bonjour,

J'avis réussi l'installation de Salome-Meca-2010.2 dans mon pc (Ubuntu12.04 32bit). Mais j'ai rencontré des problèmes quand je lance le programme. Voici les erreurs affichés dans le terminal:

--------------------------------- x --------------------------------- x --------------------------------- x --------------------------------- x --------------------------------- x --------------------------------- x ---------------------------------
      hp@ubuntu:~/SALOME-MECA-2010.2-LGPL-i386$ ./runSalomeMeca

      python: relocation error: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
      python: relocation error: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
      python: relocation error: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
      dirname: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by dirname)
      python: relocation error: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux.so.2 with link time reference
      /bin/bash: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: version `GLIBC_2.11' not found (required by /bin/bash)
      /bin/bash: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: version `GLIBC_2.8' not found (required by /bin/bash)
      /bin/bash: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: version `GLIBC_2.15' not found (required by /bin/bash)
      /bin/bash: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /bin/bash)
      /bin/bash: /home/hp/SALOME-MECA-2010.2-LGPL-i386/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /lib/i386-linux-gnu/libtinfo.so.5)
--------------------------------- x --------------------------------- x --------------------------------- x --------------------------------- x --------------------------------- x --------------------------------- x ---------------------------------

Je comprends rien du tout sur ces erreurs et le Salome-Meca est installé sous le répertoire /home/hp/SALOME-MECA-2010.2-LGPL-i386 dans mon pc. C'est ma première fois d'utiliser ce logiciel à cause de mon stage dans entreprise. Je vous remercie par avance pour votre aide.

Cordialement

==========================

Hello,

I've installed successfully Salome-Meca in my computer (Ubuntu 12.04 32bit). But when I execute it, it is stopped by some errors that I cannot understand :
      (Please see the errors above between the remarks)
The Salome-Meca is installed in the directory /home/hp/SALOME-MECA-2010.2-LGPL-i386. I'm new in Ubuntu and it's my first time to use Salome-Meca and Code_Aster cause I need it in my internship. It's really be thankful if someone can help me to solve this problem as soon as possible.

Thank you a lot !

Last edited by yoursbh (2012-07-24 10:26:05)


SALOME-MECA 2014.1 (Salomé 7.3.0 + Code_Aster 11.5) sous Ubuntu 13.10 64bit

Offline

 

#2 2012-07-04 21:13:23

delmas
Administrator
From: EDF R&D
Registered: 2007-12-12
Posts: 826

Re: [RESOLU] Problème installation Salome-Meca-2010.2

Is libc6 installed on your computer ?


Code_Aster release : unstable on (Ubuntu Precise Pangolin 12.04 64 bits) - GNU + Intel

Code_Aster. What else ?

Offline

 

#3 2012-07-05 10:32:46

yoursbh
Member
From: INSA Rouen, FRANCE
Registered: 2012-07-04
Posts: 75
Website

Re: [RESOLU] Problème installation Salome-Meca-2010.2

delmas wrote:

Is libc6 installed on your computer ?

Yes, it's installed.


SALOME-MECA 2014.1 (Salomé 7.3.0 + Code_Aster 11.5) sous Ubuntu 13.10 64bit

Offline

 

#4 2012-07-05 15:51:26

yoursbh
Member
From: INSA Rouen, FRANCE
Registered: 2012-07-04
Posts: 75
Website

Re: [RESOLU] Problème installation Salome-Meca-2010.2

Well, I've found the solution to my problem. Here's the solution for those who has the similar problem :

http://www.salome-platform.org/forum/fo … #877388471

Thank you all the same !


SALOME-MECA 2014.1 (Salomé 7.3.0 + Code_Aster 11.5) sous Ubuntu 13.10 64bit

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2005 Rickard Andersson