FORMA02 - Practical works of the formation “Initiation”: pipe bent under thermomechanical and dynamic request

Summary:

This test corresponds to practical works of the basic training to the use of Code_Aster. It is about a bent piping, made up of a linear elastic material, subjected to various loadings: internal pressure, thermal transient, transitory force.

Modelings used are the following ones:

- modeling a: modeling 3D, thermomechanical calculation,
- modeling b: modeling 3D, dynamic, modal calculation then transitory,
- modeling C: elements hulls DKT, mechanical calculation under internal loading of pressure,
- modeling D: elements beams (POU_D_T), dynamic calculation.

The chapter 1 “Problem of reference” presents the problem to be treated and the data common to all modelings; the statements of Practical works of the formation are included in this document:

- TP2: “thermoelastic 3D” to see modeling A,
- TP2: “dynamic 3D” to see modeling B.
1 Problem of reference

1.1 Geometry

The study relates to a piping including two right pipes and an elbow [Figure 1.1-a]. The geometrical data of the problem are the following ones:

- the length $L_G$ of the two right pipes is of $3 \, m$,
- the ray $R_c$ elbow is of $0.6 \, m$,
- the angle $\theta$ elbow is of $90 \, ^\circ$,
- the thickness $e$ right pipes and elbow is of $0.02 \, m$,
- and the external ray $R_e$ right pipes and elbow is of $0.2 \, m$.

![Figure 1.1-a](image)

Note:

The geometry of the problem has a symmetry compared to the plan $(A, X, Y)$.

1.2 Material properties

For all modeling With, B, C and D:

- Isotropic linear elastic material. The properties of material are those of steel $A42$ with $20 \, ^\circ C$:
  - the Young modulus $E = 204 \, 000, \times 10^6 \, N/m^2$,
  - the Poisson's ratio $\nu = 0.3$.

For thermoelastic calculation (modeling A):

- the thermal dilation coefficient $\alpha = 1.096 \times 10^{-5} / ^\circ C$,
- thermal conduction $\lambda = 54.6 \, W/m^0C$,
- voluminal heat $\rho Cp = 3.71 \times 10^5 J/m^3 \, ^\circ C$,
For dynamic calculation (modeling S B, D):
- density \( \rho = 7800 \text{ kg/m}^3 \).
- the damping of the clean modes will be taken with 5% for the modes.

1.3 Boundary conditions and loadings

The boundary conditions for all modelings are the following ones:
- embedding on the level of the section \( A \),
- at the time of static loadings, embedding on the level of the section \( A \) and of the section \( B \).

With regard to static calculations, the loadings applied are of three types:
- internal pressure (on the inner face) \( P = 15 \times 10^6 \text{ N/m}^2 \) (modeling hulls or 3D),
- thermomechanical loading with a transient of temperature imposed on the inner face of piping (assembled 20\(^\circ\)C with 70\(^\circ\)C in 10s) and a condition of null exchange on the external face of piping (heat insulator) (modeling A only).

With regard to dynamic calculation, the loading applied is a transitory force (in Newton):
\[
FY(t) = 10 000 000 \sin(2 \pi \text{Freq 1}.t) \text{ directed according to the axis } Y \text{ and applied to the section } B \text{ with Freq 1 = 20 Hz}.
\]
2 Reference solution

2.1 Method of calculating used for the reference solution

The reference solution is obtained numerically, it thus acts only of the tests of nonregression.

2.2 Results of various modelings:

2.2.1 Static calculation

The values tested are:

- for loading of pressure (modeling S With and C), it displacement at higher exit of elbow on average surface (as in the figure in lower part in white, \( \Delta X \) with \(-4.52 \times 10^{-4} \) m)
- for the loading thermomechanical (modeling A), the temperature in internal wall at the bottom of tube (70°C) as well as the constraint maximum Von Mises of about 200 MPa.

2.2.2 Dynamic calculation

The values tested are:

- For modeling 3D (modeling B), the first Eigen frequency of about 9 Hz and Lhas component of displacement \( \Delta Y \) point P at the end of piping on the average surface (as in the figure in lower part in white) of the order of \(-0.128 \) m at the moment 1s.
- For modeling 1D (modeling D), the constraints equivalent in foot of tube.
3 Modeling A

3.1 Characteristics of modeling

Glossary: in Salomé one indicates by:
• vertex points useful for the construction of the geometry;
• edge lines (right);
• arc arcs of a circle;
• wire lines made up of edge and arc;
• face the surfaces delimited by one wire;
• Shell a set of face intended to be with a grid or delimiting a volume;
• compound a set of geometrical entities.

The right pipes and the elbow are modelled by quadratic isoparametric solid elements.
Piping presents a symmetry plane $Z=0$. Only one half volume is netted.

Boundary conditions and loading: to see chapter 1.3.

3.2 Geometry

To launch the module Geometry platform Salomé-Meca.

Two processes to create the geometry (to recommend the deuxième):
• Extrusion of a basic surface according to a way:
  1. Creation of the points $Ae1$, $Ai1$, $Ae2$, $Ai2$, $Pe1$, $Pi1$, then Dbe arcs of a circle $L1$ and $L2$, Dbe segments $d1$ and $d2$ (Menu New Entity → Lowic → Not/arc/Line).
  2. Creation contour (wire) delimited by $L1$, $d1$, $l2$, $d2$ and then of surface (object of the type “Face”) starting from this contour (Menu New Entity → Build → wire/Face).
  3. Creation of the telegraphic way: points $A$, $C$, $D$, $B$, $O$, then two lines $AC$ and $DB$, and the arc of a circle $CD$, finally the total way $ACDB$ in wire.
  4. This surface is then extruded by the menu New Entity → Generation → Extrusion Withlength Path.

• Use of basic voluminal objects:
1. To build a right pipe of axis $Z$ (option by default), using two elementary cylinders height 3 and of rays 0.2 and 0.18 (Menu New Entity $\rightarrow$ Primitives $\rightarrow$ Cylinder), and of a Boolean operation (Menu OperationS $\rightarrow$ Boolean $\rightarrow$ CC). To re-elect the object created in $TUY1$.

2. To apply a rotation to $TUY1$ around $X$ so that it is of axis $Y$ (Finely Operations $\rightarrow$ Transformation $\rightarrow$ Rotation): $\text{Angle} = -90^\circ$ and to disable Create has Copy.

3. To select the higher face by creating a group: Menu New Entity $\rightarrow$ Group $\rightarrow$ Create Group. This face allows to generate the elbow by the menu New Entity $\rightarrow$ Generation $\rightarrow$ Revolution ($\text{Angle} = -90^\circ$). It is necessary for that to create the axis of revolution (a vector of direction $Z$ passing by the point $O$ $(0.6, 3.0, 0.0)$): Creation of the points $(0.6, 3.0, 0.0)$ and $(0.6, 3.0, 1.0)$ and then creation of the vector (Menu New Entity $\rightarrow$ Lowic $\rightarrow$ Vector).

4. Then to create the second right pipe in the same way $TUY2$ : to select the higher face of the elbow by creating a group, and to generate the right pipe by the menu New Entity $\rightarrow$ Generation $\rightarrow$ Extrusion according to $X$.

5. It remains to select half of the piping located in the plan $Z>0$. For that one can initially créer un plan (Menu New Entity $\rightarrow$ BASIC $\rightarrow$ Plane, for example, the 5th choice of Plane (creation starting from the system local of the coordinates), with the option OXY and cuts it 8). Then Couper with the assistance of partition (Menu Operations $\rightarrow$ Partition) by selecting the 3 parts of piping like Objects and the plan like Tool Objects.

6. Créer one group of volume by selecting Lbe partS locatedS in $Z>0$ (Finely New Entity $\rightarrow$ Group $\rightarrow$ Creat Group), and finally with this group to create one “compound”(Finely New Entity $\rightarrow$ Build $\rightarrow$ Compound).

**Preparation of the geometry for a grid in hexahedrons:**
The pipe is intended to be with a grid with hexahedrons, i.e. in a regulated way (the number of elements is identical on two side opposite). Before carrying out the grid, it is necessary to check that the geometry is topologically equivalent to a hexahedron (6 faces). For that, it is necessary to use the menu Inspection $\rightarrow$ Check Compound of Blocks.

According to the method of construction (the 1st process), it can be necessary to carry out a partition byx plans of the sections entered and exit of elbow in order to obtain a geometry topologically equivalent to a hexahedron (6 faces). To create the two plans, finely New Entity $\rightarrow$ Basic $\rightarrow$ Plane: not + Vector thus Channel $+$ AC / D $+$ COMIC). For the partition, menu Operations $\rightarrow$ Partition.

If one wants to make a grid with tetrahedrons, this condition is not necessary. On the other hand, if one wants to net in hexahedron, it is essential for the algorithms of the mailleurs.

**Creation of the groups:**
One will create then the groups of faces where one wishes to put limiting conditions: Base, Symmetry, Efond, Surfint and Surfext (Menu New Entity $\rightarrow$ Group $\rightarrow$ Create Group).

One will create also the group of edge with an edge thickness ($d1$) and another group of edge with an edge of circumference ($L1$) to allow a different refinement on these edges.

One will be able to test the other mode of use of module Geometry / Mesh, consisting to produce, possibly to modify, and read again a file python, which contains all the instructions necessary to the construction of the geometry. One creates this file by the menu File $\rightarrow$ Dump Study. This file python can be read again by the menu File $\rightarrow$ Load Script. This makes it possible in particular to modify dimensions of the geometry. As example, one will be able to examine the contents of the file forma02a.datg, and to read again it in Salome-Meca.

### 3.3 Maillage

To launch the module Mesh platform Salomé-Meca.
The grid is defined by the menu Mesh → Create Mesh. Sélectionner geometry to be netted, then the algorithm and assumption of discretization per dimension:

- 3D Hexa Hedron (I, J, K).
- 2D Quadrangle: Mapping.
- 1D Wire Discretisation with the assumption basic Number of Segments (15 segments by edge).

Then thatlcuer grid (Finely Mesh → Compute).

To allow a different refinement according to edges, under-grids will be created by the menu Mesh → Create Sub-mesh:

- UN sub-mesh defining number segments in the thickness $d l$. Prear example, the assumption basic Number of Segments with 2 segments on $d l$ and the additional assumption “Propagation of 1D assumption one Opposite Edges”.
- One sub-mesh defining the number segments on the circumference $L$. Prear example, 10 segments on $L$ and the additional assumption “Propagation of 1D assumption one Opposite Edges”.

Then thatlcuer grid (Finely Mesh → Compute).

To create Lbe groups DE e-mailbe geometrical correspondents with the group (Menu Mesh → Create Groups FRomanian Geometry). Exporter it grid with the format MED.

To obtain a better precision, one will make pass the grid of linear to quadratic, thanks to the tool "Modification -> Convert to/from quadratic". Most curious can compare the differences in results between the two types of elements.

Remarks:
- With another smoothness of grid, it is possible to get appreciably different results. In particular, to obtain a correct solution, it is desirable to use quadratic elements.

3.4 Creation and launching of the calculation case (via AsterStudy)

To launch the module AsterStudy platform Salomé-Meca. Then in left column, to click on the mitre View box, to click right CurrentCase to add a new internship where ON definesS orders of the calculation case.

Foot-note: to add orders by the menu Commands → All show.

The study requires the first transitory thermal calculation followed by a mechanical calculation.

Principal stages for the creation and the launching of the calculation case are the following ones:

- To see the grid with format MED: Order LIRE_MAILLAGE.
- To define material: Order DEFI_MATERIAU ($E$, $\nu$, $\alpha$ in ELAS, $\lambda$, $\rho Cp$ in THER).

Thermal calculation:

- To define the finite elements used: Order AFFE_MODELE for to affect the phenomenon THERMICS and modeling in 3D with ALL.
- To affect material with all: Order AFFE_MATERIAU.
- To affect conditions with limits thermics and the loading:
  - ON has a transient of temperature imposed on surface intern Surfint piping. This rise of $20^\circ C$ with $70^\circ C$ in $10s$ is defined with the order DEFI_FONCTION: to define the data in VALE and NOM_PARA = INST.
  - This transient of temperature is imposed with Commande AFFE_CHAR_THER_F: option TEMP_IMPO, with Surfint like GROUP_MA, and the function defined as imposed temperature TEMP.
  - It is considered that piping is insulated and one does not specify a condition on external surface (what returns to a null flow).

Warning: The translation process used on this website is a "Machine Translation". It may be imprecise and inaccurate in whole or in part and is provided as a convenience.

Copyright 2020 EDF R&D - Licensed under the terms of the GNU FDL (http://www.gnu.org/copyleft/fdl.html)
Thermomechanical calculation:

To define the finite elements used: Order **AFFE MODELE** for to affect the phenomenon **MECHANICS** and modeling in 3D.

To affect material: Order **AFFE MATERIAU**. The result of thermal calculation will be applied with all as a variable ordering the behavior of mechanical material by **EVL** in the option **AFFE VARC** with the temperature of reference **NOM VARC = TEMP with 20°**.

To affect conditions with limits mechanics and the loading : Order **AFFE CHAR MECA** :
- L piping has is embedded at its two ends and it present a symmetry plane : **DDL IMPO**.
- One a pressure has surfaces intern of it of **15 MPa : PRES_ REP** (to check the direction of normal on the surface interns in Asterstudy).

To solve it problem linear static mechanics : Order **MECA STATIQUE** with the calculation of the field of temperature defined above and the same list of the moments like thermal calculation.

To calculate the field : Order **CALC CHAMP** with reuse.
- for Calcul of the stress field by elements extrapolated with nodes : **CONSTRAINT/ SIEF ELNO**.
- for Calcul of the equivalent stress field of Von Mises : **CRITERIA / SIEQ ELNO**.

Imprimer maximum values of the tensor of constraints **SIEQ ELNO with the format Result (RESULT)** and Imprimer LE fields of temperature, displacements, and stress fields with the format **MED : Order IMPR RESU**.

For launchR the calculation case, in left column, to click on the mitre History View.

3.5 Post-treatment of the results

3.5.1 With Salomé and Results

To visualize the fields and the grid deformed with some click in the mitre Results of AsterStudy. To check some values while comparing with references (see chapter 2.2.1).

One can also launch the module ParaViS platform Salomé-Meca.

- To open the file of results ( Menu File → Open Para View File ) container the “mechanical” part. To choose the field **SIEF ELNO** and then hasappliquer the filter Merge Blocks by the menu Filters.
- To open the file of results container the “thermal” part. To choose the field **TEMP** and then hasappliquer the filter Merge Blocks.
- To select of the two objects Merge Blocks then to apply the filter Attributes learns.
- To visualize the deformed grid ( Menu Filters → Common → Warp By Vector ) with Lhas temperature and Lbe forced at the points of Gauss ( Menu Filters → ELGA field To Surface ).

3.5.2 With Aster Study by adding one internship

Principal stages of second execution with Aster_Sudy Swill eront:
- Extraanger Lbe values of the field **SIEF ELNO** for an azimuth on the level of the entry of elbow (not C) in the case of load corresponding to \( F_Y \) in a table : Order **MACR LIGN COUPE**. With the option of the type **SEGMENT**, L'azimuth is defined by the way D' ends \((0.18,3.0,0.) \) and \((0.2,3.0,0.) \), for example with 10 points.
- To print the table produced with the format **XMGRACE** for the component **NOM PARA=SIYY** with Commande **IMPR TABLE** : Utiliser Filter → for the moment **NOM PARA=INST** with...
10s, and to determine the data to extract by NOM_PARA, for example, COOR_X (for X-coordinate X) and SIYY (for the component of constraint).
4 Modeling B

Glossary: in Salomé one indicates by:

- **vertex** points useful for the construction of the geometry;
- **edge** lines (right);
- **arc** arcs of a circle;
- **wire** lines made up of edge and arc;
- **face** the surfaces delimiting by one wire;
- **Shell** a set of face intended to be with a grid or delimiting a volume;
- **compound** a set of geometrical entities.

The right pipes and the elbow are modelled by quadratic isoparametric solid elements.
Piping presents a symmetry plane $Z = 0$. But contrary, with the static case, one will not benefit from it. It will be seen indeed, that the modes can leave the symmetry plane. All volume will thus be netted.

Boundary conditions and loading: to see chapter 1.3.

4.1 Geometry:

To launch the module **Geometry** platform Salomé-Meca.

Two processes to create the geometry (to recommend the deuxième):

- Extrusion of a basic surface according to a way:
  1. Creation of the circles interior and external of the base on the plan $O\overline{XZ}$ (Menu New Entity → Lowic → Circle), then the surface delimited by the two circles (Menu New Entity → Build → Face).
  2. Creation of the telegraphic way: points $A, C, D, B, O$, then two lines $AC$ and $DB$, and the arc of a circle $CD$ (Menu New Entity → Lowic → Not/Line/Arc), then it way entirer (Menu New Entity → Build → Wanger).
  3. This surface is then extruded by the menu New Entity → Generation → Extrusion Withlength Path.

- Use of basic voluminal objects:

---

*Warning*: The translation process used on this website is a "Machine Translation". It may be imprecise and inaccurate in whole or in part and is provided as a convenience.

*Copyright 2020 EDF R&D - Licensed under the terms of the GNU FDL (http://www.gnu.org/copyleft/fdl.html)*
1. To build a right pipe of axis $Z$, using two elementary cylinders height 3 and of rays 0.2 and 0.18 (Menu New Entity $\rightarrow$ Primitives $\rightarrow$ Cylinder), and of a Boolean operation (Menu OperationS $\rightarrow$ Boolean $\rightarrow$ CC). To re-elect the object created in TUY1.

2. To apply a rotation to TUY1 around $X$ so that it is of axis $Y$ (Finely Operations $\rightarrow$ Transformation $\rightarrow$ Rotation); Angle $= -90^\circ$ and to disable Create has Copy.

3. To select the higher face by creating a group: Menu New Entity $\rightarrow$ Group $\rightarrow$ Create Group. This face allows to generate the elbow by the menu New Entity $\rightarrow$ Generation $\rightarrow$ Revolution (Angle $= -90^\circ$). It is necessary for that to create the axis of revolution (a vector of direction $Z$ passing by the point $O$ $(0.6, 3.0, 0.0)$): Creation of the points $(0.6, 3.0, 0.0)$ and $(0.6, 3.0, 1.0)$ and then creation of the vector (Menu New Entity $\rightarrow$ Lowic $\rightarrow$ Vector).

4. Then to create the second right pipe in the same way TUY2 : to select the higher face of the elbow by creating a group, and to generate the right pipe by the menu New Entity $\rightarrow$ Generation $\rightarrow$ Extrusion according to $X$.

5. Finally to assemble 3 parts of piping with the assistance of partition (Menu Operations $\rightarrow$ Partition).

**Preparation of the geometry for a grid in hexahedrons:**

For a grid in hexahedrons, it is necessary to use the algorithm "HexaHedron (I, J, K)" or to use the option "Automatic HexaHedralization".

The pipe is intended to be with a grid with hexahedrons, i.e. in a regulated way (the number of elements is identical on two side opposite). Before carrying out the grid, it is necessary to check that the geometry is topologically equivalent to a hexahedron (6 faces). For that, it is necessary to use the menu Inspection $\rightarrow$ Check Compound of Blocks.

According to the method of construction (the 1st process), it can be necessary to carry out a partition by plans of the sections entered and exit of elbow in order to obtain a geometry topologically equivalent to a hexahedron (6 faces). For the geometry generated following the first process, several should be created plans for partitionner piping: a plan $Y = 3$, a plan $X = 0.6$ (Menu New Entity $\rightarrow$ BASIC $\rightarrow$ Plane : not + Vector thus Channel + AC / D + COMIC ), and a surface curved to leave D U way ACDB created ( Wire_1 ) : m enu New Entity $\rightarrow$ Generation $\rightarrow$ E xtrusion S uvivant axis Z, then Operations/Transformation/Translation so that curved surface cut entirely piping.

If one wants to make a grid with tetrahedrons, this condition is not necessary. On the other hand, if one wants to net in hexahedron, it is essential for the algorithms of the maillers.

**Creation of the groups**:

One will create then the groups of faces where one wishes to put limiting conditions: Base (surface in bottom to embed), Efond (end of the pipe to apply the dynamic force): Menu New Entity $\rightarrow$ Group $\rightarrow$ Create Group.

One will create also the group of edge with an edge thickness ($d1$) and another group of edge with an edge of circumference ($L1$) to allow a different refinement on these edges.

For postprocessing it is practical to create a group on a point where one can follow the evolutions. One will thus create the group not $B$ located on the section Efond, bellow, on surface intern pipe.
4.2 Grid

To launch the module Mesh platform Salomé-Meca.

The grid is defined by the menu Mesh → Create Mesh. Sélectionner geometry to be netted, then the algorithm and assumption of discretization per dimension:

- 3D Hexa Hedron \((I, J, K)\).
- 2D Quadrangle: Mapping.
- 1D Wire Discretisation with the assumption basic Number of Segment (15 segments by edge).

Then thatlculer grid (Finely Mesh → Compute).

To allow a different refinement according to edges, under-grids will be created by the menu Mesh → Create Sub-mesh:

- UN sub-mesh defining number segments in the thickness \(d1\). Prear example, the assumption basic Number of Segments with 2 segments on \(d1\) and the additional assumption “Propagation of 1D assumption one Opposite Edges “.
- One sub-mesh defining the number segments on the circumference \(L1\). P rear example, 2 0 segments on \(L1\) and the additional assumption “Propagation of 1D assumption one Opposite Edges “.

Then thatlculer grid (Finely Mesh → Compute).

To create Lbe groups DE e-mailbe geometrical correspondents with the group (Menu Mesh → Create Groups FRomanian Geometry).

Exporter it grid with the format MED.

To obtain a better precision, one will make pass the grid of linear to quadratic, thanks to the tool “Modification - > Convert to/from quadratic”. Most curious can compare the differences in results between the two types of elements.

Remarks:

With another smoothness of grid, it is possible to get appreciably different results. In particular, to obtain a correct solution, it is desirable to use quadratic elements.
4.3 Creation and launching of the calculation case

Principal stages of calculation with AsterStudy will be:

- Preparation of the data and analyzes modal:
  - Langer grid by LIRE_MAILLAGE
  - To affect the type of elements and modeling by AFTE_MODELE
  - To define and affect material by DEFI_MATERIAU and AFTE_MATERIAU
  - To define the boundary conditions by AFTE_CHAR_MECA : option DDL_IMPO to embed base.
  - To assemble the matrices of mass and rigidity of the system by ASSEMBLY:

```
ASSEMBLY (MODELE=...,
  CHAM_MATER=...,
  CHARGE=...,
  # Classification of the unknown factors of a system
  # of equations linear
  NUME_DDL=CO ('...'),
  MATR_ASSE= (_F (MATRICE=CO ('...'),
    OPTION=' RIGI_MECA'),
    _F (MATRICE=CO ('...'),
    OPTION=' MASS_MECA'),),),)
```

- To calculate them 10 first clean modes by CALC_MODES

```
CALC_MODES (MATR_RIGI=...,
  MATR_MASS=...,
  OPTION=' PLUS_PETITE',
  CALC_FREQ=_F (NMAX_FREQ= 10 ,),) 
```

- To extract and visualize the clean modes by IMPR_RESU.

One will launch then calculation in the module AsterStudy. One recommends to visualize animations in the mitre Results of Asterstudy. One will be able also to visualize the modes in Paravis by “deforming them”: 

Warning : The translation process used on this website is a "Machine Translation". It may be imprecise and inaccurate in whole or in part and is provided as a convenience.

Copyright 2020 EDF R&D - Licensed under the terms of the GNU FDL (http://www.gnu.org/copyleft/fdl.html)
• To click right the file of the results in the mitre Box View → Dated Files, and to click Open In Paravis to charge the results by choosing the format mode instead of time, then to click Apply to validate
• To apply the filter in Filters → Normal Mechanics → modes animation (real), and to validate
• To display the window Animation view (finely View → Windows → View animation), and to add an animation for the filter above by clicking + beside Normalmodesanimationreal
• To choose the mode to be visualized (Mode Array Selection) in the window Properties on the left and to validate, then to click the button Play (►) to visualize the movement of mode

Transitory analysis
For the transitory analysis starting from the calculated clean modes, one will leave the “wizard” below. One will add to it the orders necessary following the analysis.

• To continue calculation in a new internship by the order CONTINUATION
• Definition of temporal discretization using order DEFI_LIST_REEL: of 0s with 2.0s with a step of time of 0.001s.

Construction of the specific force
• Definition of the load unit (value with 1) “force on the section B ” (AFFE_CHAR_MECA/FORCE_FACE).
• Calculation of the elementary vectors forces (CALC_VECT_ELEM/ OPTION='CHAR_MECA').
• Assembly of the vector forces (ASSE_VECTEUR).
• Definition of the function évolutée with time by FORMULA : VALE for the expression \( FY(t) = 1000000 \sin(2\pi Freq1.t) \) directed according to the axis Y and applied to the section B, where \( Freq1 = 20 \text{ Hz} \). The variables should initially be declared used in the formula.
• To evolve the function by CALC_FONC_INTERP according to the definite list of the moments. With PROL_GAUCHE/DROITE = CONSTANT to define the curve out the framework of the list of the moments.

Transient on modal basis
• Projection of the problem assembled on the basis as of clean modes PROJ_BASE (BASE=...,
MATR_ASSE_GENE= (  # For the matrix of mass
_F (MATR_ASSE = ... ),  
# For the matrix of rigidity
_F (MATR_ASSE = ... ),  
# For the dynamic force
VECT_ASSE_GENE= _F (TYPE_VECT = 'FORC',
            VECT_ASSE = ... ),)).
• Transitory calculation by modal recombination (DYNA_VIBRA)
DYNA_VIBRA (TYPE_CALCUL=' TRAN',
BASE_CALCUL=' GENE',
SCHEMA_TEMPS= _F (DIAGRAM = 'DIFF_CENTRE'),
AMOR_MODAL =...,
MATR_MASS = ... ,
MATR_RIGI = ... ,
EXCIT = ... ,
INCREMENT =...,
... ).
• Recovery of displacements in Y at the point B (RECU_FONCTION): RESU_GENE,
GROUPE_NO, NOM_CHAM=DEPL, NOM_CMP=DY.
• Impression of these functions to the format XMGRACE (IMPR_FUNCTION): FORMAT, UNIT, CURVE, etc.
• To visualize the fields of displacement:
  1. Order REST_GENE_PHYS : because the type of the results generated (bases physical) directly by DYNA_VIBRA cannot print with the format MED by IMPR_RESU , it is necessary to restore in the physical base of the results in coordinates generalized while giving LIST_INST, NOM_CHAM, RESU_GENE. Caution: the steps of many times lead very heavy file MED, and one recommends to redefine a list of the moments, for example with a step of time 0.01s.
  2. Order IMPR_RESU: to print with the format MED

4.4 Post-treatment of the results

One can visualize directly the curve of displacements DY at the point B in function time afterwards IMPR_FUNCTION with format XMGRACE.

To import the transitory results in the Results mitre, and to check displacements DY on a point at the end of the pipe (see chapter 2.2.2).
5 Modeling C

In the case of modeling in elements hulls, the grid consists of the discretization of average surface piping. Geometry being symmetrical compared to the plan \((A, X, Y)\), only one half-surface is netted.

Boundary conditions and loading: embedding at the two ends of piping, and pressure on the surface intern.

5.1 Geometry

One can create this geometry by defining the points \(A_1\), \(P\) and \(A_2\), then the arc of a circle \(Base\) (Menu New Entity → Lowic → Not/Arc). It is then enough to create the first right pipe \(AC\) starting from the arc of a circle \(Base\) by the menu New Entity → Generation → Extrusion: Vector = OY, Height = 3.

To create the elbow, it is necessary to recover the end of the pipe \(AC\) while applying the menu New Entity → Explode (Edge), then to create a vector parallel with axis Z and passing the point O \((0.6, 3.0, 0.)\). Then Générer geometry of Coude by the menu New Entity → Generation → Revolution.

Lastly, to apply the same approach for the pipe \(DB\) (Explode then Extrusion).

Créer one "compound" (Menu New Entity → Build → Compound) while selecting three parts of piping.

One will create then the groups ofS meshes where one wishes to put limiting conditions: Base, Symmetry, Efond and surface of the pipe (Menu New Entity → Group → Create Group).

One will create also the group not \(A_1\).

5.2 Maillage

To launch the module Mesh platform Salomé-Meca.
The grid is defined by the menu Mesh → Create Mesh. Sélectionner geometry to be netted, then the algorithm and assumption of discretization per dimension:

- 2D Quadrangle : Mapping.
- 1D Wire D iscretisation with the assumption basic Number of Segment (15 segments by edge).

Then to calculate the grid Finely (Mesh → Compute).

To allow a different refinement according to edges, one will create one under-grid (Finely Mesh → Create Sub-mesh) defining the assumption basic Number of Segment on the circumference, for example 10 segments on base and the additional assumption “Propagation of 1D assumption one Opposite Edges”.

Then thatculer grid (Finely Mesh → Compute).

To create Lbe groups DE e-mailbe geometrical correspondents with the group (Menu Mesh → Create Groups FRomanian Geometry).

Exporter it grid with the format MED.

5.3 Creation and launching of the calculation case (via AsterStudy)

To launch the module AsterStudy platform Salomé-Meca.

Then in left column, to click on the mitre View box.

One defines the command file of the calculation case.

Foot-note: to add orders by the menu Commands → All show.

Principal stages this mechanical calculation for the creation and the launching of the calculation case are the following ones:

- To see the grid with format MED: Order LIRE_MAILLAGE.
- To define the finite elements used: Order AFFE_MODELE. Lpiping has serhasmodelledE by elements of hull (DKT).
- To direct normals with the elements: Order MODI_MAILLAGE/ ORIE_NORM_COQUE in the same way to direct all the elements, with a normal turned towards the interior of the pipe (being given the convention of sign on the pressure) in order to give a positive value to the pressure (to use the group surface).
- To define material: Order DEFI_MATERIAU :E, NAKED, ALPHA
- To affect material: Order AFFE_MATERIAU. The mechanical characteristics are identical on all the structure.
- To affect Lbe characteristics elements hulls: Order AFFE_CARAC_ELEM/HULL to define the thickness.
- To affect conditions with limits mechanics and itS loadingS : Order AFFE_CHAR_MECA :
  - There is an embedding on the group of meshes Base and Efond, and conditions of symmetry (normal displacement DZ no one and rotations DRX and DRY worthless) on the group of meshes Symetrie : DDL_IMPO.
  - An internal pressure $P$ : PRES_REP. It is necessary to convert the pressure $P$ on the surface intern in the pressure on the average surface.
- To solve it problem rubber band : Order MECA_STATIQUE : CARA_ELEM, CHAM_MATER, EXCIT, MODEL.
- To print displacements and the constraints with the format MED : Order IMPR_RESU..
- For launchR the calculation case, in left column, to click on the mitre History View.
6 Modeling D

6.1 Geometry

One can create the geometry by defining the points \(A, C, D, B\), then two lines \(AC\) and \(DB\), and the arc of a circle \(CD\). This can be done in several ways:

- By defining the coordinates of each point, including the point medium of the arc \(CD\) (Menu New Entity → Lowic → ...);
- In a simpler way by using L’tool "Sketcher" (Menu New Entity → Lowic → 2D Sketch).

For having built the whole of the line, it is necessary to define the groups under this "Wire": it will be enough for these practical works to create the groups \(A, B, AC, CD,\) and \(DB\) (Menu New Entity → Group → Create Group).

6.2 Maillage

To launch the module Mesh platform Salomé-Meca.

The grid is defined by the menu Mesh → Create Mesh. Sélectionner geometry to be netted, then the algorithm and assumption of discretization per dimension: 1D Wire Discretisation with the assumption of 15 segments by edge.

6.3 Creation and launching of the calculation case (via AsterStudy)

To launch the module AsterStudy platform Salomé-Meca.

Then in left column, to click on the mitre View box.

One defines the command file of the calculation case.

Foot-note: to add orders by the menu Commands → All show.

The study requires the first transitory thermal calculation followed by a mechanical calculation.

Principal stages for the creation and the launching of the calculation case are the following ones:

- To see the grid with format MED: Order LIRE_MAILLAGE.
- To define the finite elements used: Order AFFE_MODELE.
- To define material: Order DEFI_MATERIAU.
- To affect material: Order AFFE_MATERIAU.
- To affect characteristics of the elements beams: Order AFFE_CARA_ELEM.
- To affect conditions with limits mechanics and the loading: Order AFFE_CHAR_MECA/Enforce DOF (DDL_IMPO). The point \(A\) is embedded.
- To define Lbe matrices of the elastic problem: Order ASSEMBLY/ MASS_MECA and RIGI_MECA.
- Calculator Lbe the first 5 clean modes: Order CALC_MODES.
- Imprimer Lbe clean modes with the format MED: Order IMPR_RESU. One will print the grid and the modes.

For launchR the calculation case, in left column, to click on the mitre History View.

Transitory analysis:

- Construction of the specific force
  1. To affect Load has “forces at the point \(B\)”: Order AFFE_CHAR_MECA / FORCE_NODALE.
  2. Calculationer Lbe elementary vectors forces: Order CALC_VECT_ELEM.
3. To build a field with the nodes by hassemblage of the vector forces : Order ASSE_VECTEUR.
4. To define the function evolution of time : Order FORMULA.

- Transient on modal basis
  1. Projection of the problem assembled on the basis of clean mode : Order PROJ_BASE.
  2. Calculationer it transient by modal recombination : Order DYNA_VIBRA.
  3. To extract Lbe displacements in $Y$ in $B$ : Order RECU_FONCTION.
  4. Imprimer these functions with the format TABLE : Order IMPR_FONCTION.