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FORMA01 - Travaux practices of the formation 
“Initiation”: modeling of a plate perforated in 
élastilinear city and adaptation of grid

Summary:

This test 2D in plane constraints quasi-static allows a catch in hand of the platform Salomé-Meca on a simple
case in linear elasticity.

It is about a homogeneous rectangular plate, perforated in its center, which is subjected to a traction at its ends.

Initially (modeling A), it is indicated how to build the geometry then the grid and how to put in dataS the study.
In the second time (modeling B and C), one will carry out the adaptation of the grid. Finally (modeling D), one
presents an alternative solution using method X-FEM.

The statements of Practical works of formation (TP1) are included in this document (see modelings A, B and
C).

Warning : The translation process used on this website is a "Machine Translation". It may be imprecise and inaccurate in whole or in part and is
provided as a convenience.
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1 Problem of reference
1.1 Geometry

It is about a rectangular plate, comprising a hole, modelled in 2D  plane constraints. One models only
one quarter of the  plate  thanks  to  symmetries. Dimensions are given in millimetres.
  

   
      

 
 
 

 

  

1.2 Boundary conditions and loadings

Conditions of symmetry:
The plate is blocked according to Ox  along the side AG  and following Oy  along the side BD .

Loading in imposed constraint:
It is subjected to a traction P=100MPa  according to Oy  distributed on the side FG . 

1.3 Properties of materials

The characteristics are: 
• Young modulus E=200000MPa  
• Poisson's ratio =0,3  
• Elastic limit: 200MPa  
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2 Reference solution

2.1 Elastic solution

In  elasticity,  for  a  plate  infinite,  comprising  a  hole  of  diameter  a ,  subjected  to  a  loading  P
according to y  ad infinitum, the analytical solution in plane constraints and polar coordinates r ,
is [bib1]:

 rr=
P
2 [1− ar 

2
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In particular, at the edge of the hole ( r=a ) : σθθ=P [(1+2cos2θ)]

And along the axis x  : 


= yy=
P
2 [1 ar 
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13 ar 
4

]
Numerically, for P=1MPa , and for a plate infinite, one a:

Not Component Calculation MPa  

A  SIXX  σθθ (r=a ,θ=π /2)  – 1

B  SIYY  σθθ (r=a ,θ=0)  3

For a plate of dimension  finished, the abacuses [bib1] make it possible to obtain the coefficient of
stress  concentration,  and  one  finds  that  for  a  traction  of  1MPa ,  SIYY  maximum  is  worth
approximately 3.03MPa  at the point B .

2.2 Bibliographical references

[1] Analysis  limits  fissured  structures  and  criteria  of  resistance.  F.  VOLDOIRE:  Note
EDF/DER/HI/74/95/26 1995

[2] Stress concentration factors. R.E. PETERSON Ed. J. WILEY p150
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3 Modeling A

3.1 Unfolding of the TP

It is a question of concluding the elastic design by generating the geometry, the grid and the command
file AsterStudy using the platform Salomé-Meca.
Modeling is C_PLAN rubber band. A quarter of the plate is modelled.  One will also define the orders
necessary to the examination (traced graphic curves and postprocessings). 

3.1.1 Geometry

One will create the plane face of the quarter higher right DE the plate.

To launch the module Geometry.

Principal stages to build this geometry are the following ones : 
• To define contours of the plate, one can, for example, to use the tool “ Sketcher ” (Finely

New Entity  →  Lowic → 2D Sketch ) .  It  is  simpler  of  commencer by  not B  of

coordinates (10,0)  . On the basis of B  , for the arc of a circle, to use Standard element
(Withrc) and Destination (Direction/Perpendicular) , and to define the ray  10
and L' angle and the ray 90°. The point is obtained A   . Then to use Standard element
(Line) and Donner other points ( G ,  F ,  D ) by their absolute coordinates. To finish by
Closure sketch. 

• A closed contour is then obtained (Sketch_ 1 ) on which one must build a face ( Menu New
Entity → Build → Face ) . The geometry of the plate is then complete. 

• To build useful groups for calculation. Here one builds the 3 groups Dbe edges on which the
boundary conditions (symmetries and loading) will be pressed: left for the edge AG  , high
for the edge  GF  and  low for the edge  BD .   Menu  New Entity → Group → Create
Group : To select the geometrical type of entity (here the line, edge) and to select the edge
directly in the chart window, Ensuite to click on Add, UN number of object must then appear.
One can change the name of the group before LE to validate by Apply. 

3.1.2 Grid

One will create a grid plan of the quarter higher right of the plate, in elements of order 2, to have a
sufficient precision.

To launch the module Mesh.

Principal stages for to generate the grid are the following ones : 
• To build grid ( Menu Mesh → Create Mesh ) . To select geometry to be netted Face_1, then

to choose Withlgorithm → NETGEN 1D-2D while adding Hypothelocated → NETGEN
2D Parameters. On this assumption, to select Fineness → Fine and coachman the box
Second Order before Apply. 

• Calculer it grid (Finely Mesh → Compute ) . A window of information of grid must appear, and
ON obtains a free grid then. 

• To create Lbe groups DE e-mailbe correspondents with the groupS geometrical ( Menu Mesh
→ Create Groups FRomanian Geometry ) . Selectionner all them 3 groups edges under
module Geometry and then Apply. One obtains 3 groups of the edges on the grid. 

• To obtain a better precision, one will make pass the grid of linear to quadratic, thanks to the
tool “ Modification - > Convert to/from quadratic ”. Most curious can compare
the differences in results between the two types of elements.

• (Optional) Exporter it grid with format MED: to select  Mesh_1 and to click right-hand side,
then to choose Export/MED slips by.
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Note:
This grid is sufficiently fine (with quadratic elements) to have a good approximation of the solution
in elasticity: for example if one compares σθθ  on the edge of the hole compared to the analytical
solution, one obtains a variation of less than 5%.
 
The geometry and the parameters of grid are defined in the file forma01a.datg associated with
the test. The produced grid is stored in the file forma01a.mmed.

   

3.2 Creation and launching of the calculation case (via AsterStudy)

To launch the module AsterStudy.
Then in left column, to click on the mitre  View box. In the box  Settings dated, to click on the
right with  CurrentCase and to choose Add Internship. It is in  Stage_1 where ON defines the
command file of the calculation case. 

Foot-note: to  seek  orders  by  Menu  Commands → All show however  by  the  10  categories  of
calculation:  Mesh,  Model Definition,  Material,  Functions and Lists,  BC and Load,  Pre
Analysis, Post Processing, Fracture and Tiredness, Output.

Principal stages for the creation and the launching of the calculation case are the following ones:
• To see the grid with format MED: Category Mesh / Order LIRE_MAILLAGE. Grid in the module

MESH is available in the list. If not the button behind makes it possible to choose a grid in the
repertoires.

• To direct Lhas normal edge on which the loading of traction will be applied : Category Mesh /
Order  MODI_MAILLAGE/ORIE_PEAU_2D in  affecting the  group  hauT in  GROUP_MA. One
keeps the same name of the grid while using reuse.

• To define Lbe finite elements used: Category Model Definition / Order  AFFE_MODELE for
modeling in plane constraints 2D ( C_PLAN ). To add a term in  AFFE. In this term, to affect
YES to ALL elements, and to choose the phenomenon MECHANICS, and to add the term of
plane constraints 2D ( C_PLAN ) in modeling

• To define material: Category Material / Order  DEFI_MATERIAU . To choose ELAS and to
seize the values of the Young modulus and the Poisson's ratio.

• To affect material: Category Material/ Order AFFE_MATERIAU. To define at least an option
enters GRID and MODEL. To add a term in AFFE, and to affect material defined in ALL.

• To affect conditions with limits mechanics and the loading : Category BC and Load / Order
AFFE_CHAR_MECA : 
◦ for Symetry on the quarter of plate: DDL_IMPO. For left, DX=0, and for low, DY=0.
◦ for Traction: PRES_REP. For high, to seize traction with NEAR (thus it is negative).

• To solve it problem linear static mechanics : Category Analysis / Order MECA_STATIQUE by
giving  material  (CHAM_MATER),  modeling  (MODEL),  boundary  conditions  and  the  loading
(EXCIT). 

• To calculate the field :  Category  Post Processing / Order CALC_CHAMP while activating
reuse (for to keep the same name of the object of entry in the order). I.e. ON will enrich the
concept resulting from MECA_STATIQUE in taking again the same name. 
◦ for Calcul of the stress field: CONSTRAINT/ SIGM_ELNO (constraints by elements with 

nodes), SIGM_NOEU (constraints total with the nodes). 
◦ for Calcul of the equivalent stress field :  CRITERIA / SIEQ_ELNO (by elements with

nodes), SIEQ_ELGA (by elements at the points of Gauss), SIEQ_NOEU (total with the
nodes).

• To print Lbe results of a calculation with format MED: Category Output / Order IMPR_RESU .
To add a term in RESU, and to choose the results to print. To define the output file (.rmed) by
UNIT.

• For launchR the calculation case, in left column, to click on the mitre History View . It is
necessary to save the study initially, and to select  CurrentCase. To add  Stage_1 while
selecting run (cross in green). Before launching, checking parameters of calculation desired
in the box Run Parameters: time limits of calculation, memory, version of code_aster etc. 
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3.3 Postprocessing of the results

To display the results,  two choices are currently  available:  mitre  Results in  AsterStudy, and the
module ParaViS. 

Choice 1   : In mitre Results in AsterStudy : 
Following postprocessings are proposed:

• To import the file of results ( Box View box →  F dated island S , to click right on the
output file and to choose Post-process . By default, the colouring of the plate by the field of
displacement DEPL , an automatic amplification is applied to the deformation of the plate. To
visualize well the difference between the initial form and the deformation, to click right to the
window and to choose Show ace/Wireframe . 

• D ouble to click the desired field, to use the button Honest been worth one one gold
more points gold concealments (symbol cross) to check the values at points A and B. 

• (optional) to go to the Paravis module, one finds the actual position of visualization and also all
the historical actions.

Choice 2 : In the module ParaViS :
Following postprocessings are proposed:

• To import the file of results (Box View box →  F datedislandS, to click right on the output
file and to choose Open in ParaVis. 

• To download the results: In the mitre  Properties the column on the left, to initially choose
the  desired  fields  to  import,  and Cocher the  option  GenerateVectors,  then hasppliquer
Apply. 

• To visualize the initial grid (noter in representation Surface With Edges). 
• Visualiser deformation of the plate ( Menu Filters  → Common → Warp By Vector with

the options Vectors = results_DEPL_Vector and ScaleFactor = 100 front Apply). 
• To visualize  the stress field  by elements with the nodes or the points Gauss: to select  the

imported  result,  then  in  Menu  Filters  → Mechanics, to  choose the  option  of  desired
visualization. 

To check  Lhas value  of  the constraints  to  the  node B: if  one finds a relationship  3  between the
constraint σθθ  (= σ yy ) at the edge of the hole and the force applied. To display the results on a node,
to activate Hover points one (like the photograph below), and to move the mouse with the desired
node. 

 

3.4 Sizes tested and results

Value of the components of constraints: 
 

Localization Identification Reference (Analytical) Tolerance

Node B Constraint SIYY 303,0 5,0%

Node A Constraint SIXX -100,0 15,0%

 
These tests on analytical values are doubled by tests of not-regression
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4 Modeling B 

4.1 Unfolding of the TP

It is a question of implementing the adaptation of grid following an elastic design.
One will thus set out again of the study carried out at the time of modeling A.

4.2 Adaptation of grid 

After  having  launched  the  module  AsterStudy,  one modify  the  command  file  for  to  add  the
calculation of the indicator of error:

• To add results of error with Commande CALC_ERREUR in the category Post Processing :
to choose itoption ERME_ELEM while using reuse.

• Relancer calculation.

To  visualize  the  error  and  stress  fields  (component  ERREST,  total  error),  one  can  carry  out
postprocessing in the mitre  Results (strongly recommended) or in the module ParaVis.  Stages in
the module ParaViS are like according to:

• C ocher fields to visualize to charge them before applying GenerateVectors  : SIEF_ELGA
, ERME_ELEM 

• For visualiser the component SIYY field  SIEF_ELGA in particular at the edge of  the hole:
Menu Filters  → Mechanics →  ELGA field To Surface and noter in representation
Surface With EdgeS. For Rto raise the position of the maximum value about ( 270MPa
 ):  Menu  Edict  → Find Dated  and to choose the option  Concealments in  the field
creates  ELGAfieldToSurface,  to select  SIEF_ELGA_Vector (1)  representative  SIYY
and formulates it max. is. 

• To visualize the cartography of the indicator of error (field ERME_ELEM , component ERREST ,
total error). 

One turns over to module AsterStudy, one modify the command file to carry out an adaptation of
grid and to then directly calculate the new value of indicator of error:

• Category  Post Processing /  Commande  MACR_ADAP_MAIL for an adaptation of  grid of
type RREFINEMENT: the new grid is named by MAILLAGE_NP1=MAIL2, to select the criterion
of  the  elements  (option  CRIT_RAFF_PE)  to 10%  for  the  parameter  of  adaptation:
RESULTAT_IN / NOM_CHAM=ERME_ELEM / Shas component  NOM_CMP = ERREST. 

• To  connect  then  orders  AFFE_MODELE,  AFFE_MATERIAU,  AFFE_CHAR_MECA,
MECA_STATIQUE, CALC_CHAMP and  CALC_ERREUR on this new grid  MAIL2 (Duplicate
orders by modifying  the grid  and other concerning terms).  Attendtion :  the names of  the
concepts of these orders should not be identical to those of front, and they do not exceed 8
characters.

• To print Lbe new results DE calculation with format MED: Order IMPR_RESU . 
• To launch calculation.

To visualize  LES fieldS of  constraint  and of  error,  one can carry  out  postprocessing in  the mitre
Results (strongly recommended) or in the module ParaVis. 

4.3 Sizes tested and results

Value of the components of constraints (SIGM_NOEU) with initial grid and after an adaptation: 

Grid Localization Identification Reference
(Analytical)

Tolerance

1 Node B Constraint SIYY 303,0 5,0%
1 Node A Constraint SIXX -100,0 15,0%

2 Node B Constraint SIYY 303,0 2,0%

Warning : The translation process used on this website is a "Machine Translation". It may be imprecise and inaccurate in whole or in part and is
provided as a convenience.
Copyright 2021 EDF R&D - Licensed under the terms of the GNU FDL (http://www.gnu.org/copyleft/fdl.html)



Code_Aster Version
default

Titre : FORMA01 - Travaux pratiques de la formation « Init[...] Date : 13/09/2019 Page : 8/13
Responsable : BEIGNION Céline Clé : V3.02.326 Révision  :

4ba933d27e36

2 Node A Constraint SIXX -100,0 3,0%

These tests on analytical values are doubled by tests of not-regression. 
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5 Modeling C

5.1 Unfolding of the TP

It is about to implement an adaptation of grid in a loop python on an elastic design.

5.2 Adaptation of grid

After having launched the module AsterStudthere and with to leave the command file of modeling
A, one adds a loop python to carry out two adaptations (Finely Operations → Text mode). One will
be able to take as a starting point the file forma01c.comm.
Calculation is launched.

After having launched the module ParaViS, one carry out following postprocessing: 
• Vto oir the effect of the adaptation on the maximum of the component SIYY stress field. The

maximum is now about 280MPa .
• To visualize the cartography of the indicator of error (component ERREST, total error).

5.3 Sizes tested and results

Value of the components of constraints for the initial grid and after an adaptation: 

Grid Localization Identification Reference
(Analytical)

Tolerance

1 Node B Constraint SIYY 303,0 5,0%

1 Node A Constraint SIXX -100,0 15,0%
2 Node B Constraint SIYY 303,0 2,0%

2 Node A Constraint SIXX -100,0 3,0%
3 Node B Constraint SIYY 303,0 1,0%

3 Node A Constraint SIXX -100,0 2,0%

These tests on analytical values are doubled by tests of not-regression. 
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6 Modeling D

6.1 Unfolding of the TP

It is a question of carrying out elastic simulation without netting the hole, by using method X-FEM.
For  that,  one uses the concept of  interface (delimiting  the hole),  an interface being seen like  an
“infinite” crack (not of face of crack). The interface is then represented by only one Level Set (Level
Set Normal), separating two solids, without contact on the interface. One models thus a hole (vacuum)
because the solid inside is insulated moreover structure to which the loading of pressure is applied. 

One  to  obstructwill  era  geometry  and  grid  and  the  command  file  AsterStudy  using  the  platform
Salomé-Meca.
Modeling is C_PLAN rubber band. A quarter of the plate is modelled.

6.1.1 Geometry

The geometry is the quarter higher right of the rectangular plate, without hole. 

To launch the module Geometry.

Principal stages to build this geometry are the following ones : 
• To create  the  face,  one can,  for  example,  to  use the  “right-angled” tool  ( Menu Right-

angled  New  Entity/Primitive/ ) ,  then  possibly  to  relocate  it  (Finely
Operations/Transformation/Translation ) . 

• To build the groups D be edges on which will be pressed the boundary conditions (symmetries
and loading) ( Menu New Entity → Group → Create Group ) . To select the geometrical
type of entity (here the line, edge ) and to select the edge directly in the chart window. Then,
to click on Add . A number of object must then appear. One can change the name of the group
before L E to validate by Apply . To thus build the 3 groups of edge useful for calculation :
left for the edge AG  , high for the edge GF  and low for the edge BD  . 

6.1.2 Grid

One will create a grid plan of the quarter higher right of the plate, in elements of order 2, to have a
sufficient precision.

To launch the module Mesh.

Principal stages for to generate the grid are the following ones : 
• To build  grid ( Menu  Mesh → Create Mesh ) .  To select geometry to be netted, then the

algorithm NETGEN  1D-2D with the  assumption NETGEN  2D  Parameters .  On  this
assumption, to select Fineness → Fine and coachman the box Second Order . 

• Calculer it grid  (Finely Mesh → Compute ) . 
• To create Lbe groups DE e-mailbe correspondents with the groupS geometrical  ( Menu Mesh

→ Create Groups FRomanian Geometry ). Selectionner all geometrical groups. 3 groups
D are obtained‘edges on the grid. 

• Exporter it grid with format MED. 
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6.2 Creation and launching of the calculation case (via AsterStudy)

To launch the module AsterStudy.
Then in left column, to click on the mitre View box . 

One defines the command file of the calculation case. 

Foot-note: To add orders: Menu Commands → All show . 

Principal stages for the creation and the launching of the calculation case are the following ones:
• To see the grid with format MED: Order  LIRE_MAILLAGE . 
• To  direct  the  grid  towards  the  affected  edge  by  the  loading:  Order 

MODI_MAILLAGE/ORIE_PEAU_2D while using the group hau T . 
• To define the finite elements used: Order  AFFE_MODELE for modeling in plane constraints 2D

( C_PLAN ). 
• To define the interface: DEFI_FISS_XFEM with the shape of crack ( FORM_FISS/ ELLIPSE )

and the type of discontinuity . 
• To create L be finite elements nouveau riches ( MODI_MODELE_XFEM ).  And to name new

name of model X-FEM. 
• To define material: Order  DEFI_MATERIAU . 
• To affect material: Order  AFFE_MATERIAU on model X-FEM. 
• To affect conditions with limits mechanics and the loading :  AFFE_CHAR_MECA on model X-

FEM  : 
◦ for Symetry on the quarter of plate: Enforce DOF (DDL_IMPO),
◦ for Traction: FORCE_CONTOUR.

• To solve it problem linear static mechanics : Order  MECA_STATIQUE on model X-FEM. 
• To create grid: Order POST_MAIL_XFEM . And to name a new name of the grid. 
• To define the finite elements used: Order  AFFE_MODELE for modeling in plane constraints 2D

( C_PLAN ). E T to name a new name of the model. 
• To create result of visualization: Order POST_CHAM_XFEM . And to name a new name of result

. 
• To calculate the field  : Order  CALC_CHAMP . 

O N will enrich the concept resulting from POST_CHAM_XFEM in taking again the same name
of concept. 

◦ for C alcul of the stress field by elements with nodes : CONSTRAINT/ SIGM_ELNO . 
◦ for Calcul of the stress field equivalent by elements to nodes : CRITERIA / SIEQ_ELNO.
◦ for Calcul of the stress field equivalent by elements to the points of Gauss: CRITERIA / 

SIEQ_ELGA . 
• To print Lbe results of a calculation with format MED: Order  IMPR_RESU . 
• For launchR the calculation case, in left column, to click on the mitre History View . 

Note:
The rigid modes of the hole are blocked by the conditions of symmetry applied. In the case of a
modeling of the whole plate, it would have been necessary to block the rigid modes of the plate
and also of those of the hole.
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6.3 Postprocessing of the results

To launch the module ParaViS. 

One will  visualize  the deformation of  the plate then the constraints at the edge of  the hole while
comparing oneself with the reference solution.

• To import the file of results ( Mitre F datedislandS → Open in ParaVis frontEC the
option GenerateVectors ). 

• Visualiser deformation of the plate ( Menu Filters → Common → Warp By Vector ) . 

One will be able to possibly add an automatic stage of refinement of grid to improve the precision of
the results.

Note:
The rigid modes of the hole are blocked by the conditions of symmetry applied. In the case of a
modeling of the whole plate, it would have been necessary to block the rigid modes of the plate
and also of those of the hole.

6.4 Sizes tested and results

Value of the components of constraints at points A and b:

For that, the field is calculated SIGM_NOEU. Attention, concept of SIGM_NOEU is particular for X-FEM
because the  elements  generated for  visualization  (by  POST_CHAM_XFEM)  have  double  nodes not
connectés. One thus has several  values for  a position of  node. In this case, there are two nodes
localisedS  at  point  A  (with  dimensions  plates)  and  two  nodes  localisedS  at  the  point  B  (with
dimensions plates). One thus tests the min and the max for each point.

 
Localization Identification Reference (Analytical) Tolerance

Node A Constraint SIXX -100,0 5,0%

Node B Constraint SIYY 303,0 5,0%

These tests on analytical values are doubled by tests of not-regression.

Warning : The translation process used on this website is a "Machine Translation". It may be imprecise and inaccurate in whole or in part and is
provided as a convenience.
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7 Summary of the results

This  test  watch  how to  carry  out  the  calculation  of  an  elastic  structure  and  how to  extract  in
postprocessing the sizes from interest. It met also in obviousness the benefit to use the adaptation of
grid to improve the precision of the results.

Warning : The translation process used on this website is a "Machine Translation". It may be imprecise and inaccurate in whole or in part and is
provided as a convenience.
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