enfr

Build a NEW11* version

Prerequisites or configuration modifications for the development version

version 11.2.x :

  • in 11.2.16, use of Metis (download here) as library. You must install Metis (make install prefix=$ASTER_ROOT/public/metis-4.0.3) and add in the config.txt file:
    • on the line DEFS : _HAVE_METIS
    • on the line INCL : -I$ASTER_ROOT/public/metis-4.0.3/include
    • on the line BIBL : -lmetis if not already there for Mumps
  • in 11.2.3, use of the include jeveux.h for fortran90:

You must add in the config.txt file on the line INCLF90:

-I$ASTER_VERSION_DIR/bibfor/include

($ASTER_VERSION_DIR will be automatically replaced by as_run by $ASTER_ROOT/unstable)

  • in 11.2.2:
    • addition of the include jeveux.h in bibfor/include: You must add in the config.txt file on the line INCLF:

-I$ASTER_VERSION_DIR/bibfor/include

    • a bug in as_run stops the construction of the code in the linking. Just delete $ASTER_ROOT/unstable/lib and re-run the construction:

rm -rf $ASTER_ROOT/unstable/lib && as_run --vers=unstable --make

version 11.1.x :

  • in 11.1.17, the version of the hdf5 API changed : version 1.8.

These changes concerns the version 10.6.7 too.

Two possible cases :

    • hdf5 use API 1.6 by default (if #define H5_USE_16_API_DEFAULT in H5pubconf.h file) : you must add H5_NO_DEPRECATED_SYMBOLS on the line DEFS in config.txt file.
    • hdf5 use API 1.8 by default (if /* #undef H5_USE_16_API_DEFAULT */ in H5pubconf.h file) : you have to remove H5_USE_16_API on the line DEFS in config.txt file.

Then, you have to remove the compiled C files et and rebuild :

as_run --make clean bibc/hdf
as_run --make

version 11.0.x :

  • in 11.0.5, the version of the Med library changed : version 3.0.

The last version of Med is available on the page Download/Tools. Hdf5 version 1.8 is required.

Compulsory : For Code_Aster, you must change the config.txt file to modify the path to the med library. On a line BIBL, replace for instance /opt/aster/public/med-2.3.6 by /opt/aster/public/med-3.0. You must also add the path to the header files (line INCL). For example, add -I/opt/aster/public/med-3.0/include. Similarly, change the path to hdf5 headers.

If the hdf5 library has not been configured with the option —with-default-api-version=v16, you must add this information in the config.txt file : add the definition H5_USE_16_API on the DEFS line.