Welcome to the forums. Please post in English or French.

You are not logged in.

#1 Re: Salome-Meca usage » Strange results with COQUE_3D model » 2020-06-19 11:55:08

Hi Anirudh,
sorry for the big delay in my answer, but I was involved in other issues, and only now I have re opened mi post.

I tried to use KEESWOUTERS suggestion, reading also his contribution to Caelinux.org Wiki, receiving only errors, essentially because a quadratic mesh (that I changed from 8 to 9 nodes using

Original = LIRE_MAILLAGE(identifier='0:1',
                         UNITE=20)

new_mesh = CREA_MAILLAGE(identifier='1:1',
                         MAILLAGE=Original,
                         MODI_MAILLE=(_F(GROUP_MA=('DX', ),
                                         OPTION='QUAD8_9'),
                                      _F(GROUP_MA=('SX', ),
                                         OPTION='QUAD8_9'),
                                      _F(GROUP_MA=('UP', ),
                                         OPTION='QUAD8_9')))

new_mesh = DEFI_GROUP(identifier='2:1',
                      reuse=new_mesh,
                      CREA_GROUP_MA=(_F(GROUP_MA=('DX', ),
                                        NOM='dx1'),
                                     _F(GROUP_MA=('SX', ),
                                        NOM='sx1'),
                                     _F(GROUP_MA=('UP', ),
                                        NOM='up1')),
                      MAILLAGE=new_mesh)

new = AFFE_MODELE(identifier='3:1',
                  AFFE=_F(MODELISATION=('COQUE_3D', ),
                          PHENOMENE='MECANIQUE',
                          TOUT='OUI'),
                  MAILLAGE=new_mesh)

elementi = AFFE_CARA_ELEM(identifier='4:1',
                          COQUE=(_F(COQUE_NCOU=3,
                                    EPAIS=2.0,
                                    GROUP_MA=('DX', 'SX')),
                                 _F(COQUE_NCOU=3,
                                    EPAIS=3.5,
                                    GROUP_MA=('UP', ))),
                          MODELE=new)

old = AFFE_MODELE(identifier='5:1',
                  AFFE=_F(GROUP_MA=('DX', 'SX', 'UP'),
                          MODELISATION=('COQUE_3D', ),
                          PHENOMENE='MECANIQUE'),
                  MAILLAGE=Original)

but this code produces errors, because new mesh is OK, but old mesh is wrong.

But, what I really don't understand, is:
in the example I sent, I modified the mesh from Quadratic to BiQuadratic using Salome SMESH module, so I'm sure that MED is able to manage 9 nodes quad elements: I imported the med file both in Salome 9.4 and in Paravis, other then in Salome-Meca2019.0.3.

It is possible to have some suggestion to a correct display of coque_3D elements?

Ciao and many thanks

#2 Re: Code_Aster usage » stress and strain in the plane of deformed shape » 2020-06-19 09:04:18

Hi Dinidu,
my opinion is that Stresses and Strains are referred to 'element reference system'.
This means that, in case your structure is a simple quadrangular plane laying in Oxy plane, using Small Displacements the two system (element vs. Global) could be coincident, but if your analysis is a Large Displacements case, so they necessarily will be divergent.
Be aware that it is only my opinion!

Ciao, Piero

#3 Salome-Meca installation » Salome-Meca FRESH installation by original source code » 2020-06-09 11:42:54

caeconsulting
Replies: 0

Hi to everybody,
I would try to build Code_Saturne 6.1 with Salome-Meca19.03 (to test fluid-structure implementation = FSI): I tried to use Salome-Meca19.03 Universal, but I discovered that it is not so universal, at least for my Ubuntu 18.04 system.
So, because to install CS610 with Salome-Meca19 I need to build before a right (for Ubuntu 18.04, obviously) SM19 version, is it possible to build by scratch Salome-Meca 19.03?
Where could I download Salome-Meca source code to try a fresh installation?

Many thanks to you all, Ciao
   Piero

#4 Re: Code_Aster usage » error code like this: _EXIT_CODE=139 [SOLVED ??] » 2020-03-10 12:03:09

Hi Konyaro,
thank you a lot for your suggestion. I read the discussion you linked, and I read the two link listed in this discussion.
At the end I agree with you: most of the time it doesn't help much though...
So I wrote [SOLVED ??]

Many thanks again
    Piero

#5 Code_Aster usage » error code like this: _EXIT_CODE=139 [SOLVED ??] » 2020-03-06 18:42:27

caeconsulting
Replies: 2

Ciao to all,
I have this error at beginning of calculation (I think it is associated with Segmentation Faults, but I'm not sure)
The problem is this: I have just installed Code_Aster 14.4.0 in my Ubuntu 18.04 system, and at the setup.log says all is OK.
When I start the execution (using astk) of a problem that Salome-Meca 2019.0.3 (installed in the same machine) solves correctly, I have the error reported here.
Some suggestion?

Many thanks
   Piero

p.s. there is a list of _EXIT _CODE somewhere?

#6 Re: Salome-Meca installation » [SOLVED] Salome-meca 2019.0.0-1 » 2020-01-04 17:04:15

dezsit wrote:

Hello,

It works me with the embedded Qt on Ubuntu (Xubuntu) 18.04, even with Shaper module
AsterStudy also, but it is very slow (comparing to 2018 version). Using the new post processing option has been freezing the SalomeMeca complately , even with a very small model.
Additionally, I can't re-open a study hdf, if the AsterStudy was activated before the saving operation, even if I don't do anything in AsterStudy, only simply activated it.
I'm curious, if anybody else has similar issue...

BR,
dezsit

I just sent an answer to an hold message with same problem: have a look to https://code-aster.org/forum2/viewtopic … 894#p60894  and let me know if it can be useful for you too.

Best regards, Piero

#7 Re: Salome-Meca usage » asterstudy just hangs » 2020-01-04 16:43:19

Hello,
I'm finding same error with 2019.0.3 too.
I solved with this workaround:
- open Salome-Meca (don't open any study)
- go to Preferences -> Salome : General Panel
-- leave unchecked "Store/restore last GUI state"
- save and close Salome-meca

By this moment I was able to re-open any study as many time I like, but only NEW studies created after the workaround.

For older studies, I tried to install latest Salome (stand-alone, without Code-Aster) version (Salome 9.4.0) : using it I was able to read old studies that hanged, and, after deleted any existent GUI State, I  saved the hdf file.
Obviously, Asterstudy was no more recoverable; but, all files are still in _Files directory and you could recall .comm file in a new Asterstudy session.

I hope it can work also for you.

Best regards
    Piero

#10 Salome-Meca usage » Strange results with COQUE_3D model » 2020-01-04 12:11:52

caeconsulting
Replies: 4

Happy New Year to everybody,
I made a test using shell (modelization COQUE_3D), but I found strange results observing deformed structure.
As you can see in  images in attached 7z file, Paravis  shows that each central node has a ZERO deformation and the shaded graphical output looks very strange.
In attache file you can find the mesh .med file, the .comm file and two snapshots showing the problem.
I can say that:
- I did all study using Salome-meca 2019-0-3 in Ubuntu 18.04
- the mesh was converted in Bi-Quadratic using Salome
- I did extraction of some fields following "Beginning with code_aster" handbook (Version 2.1.2 by Jean-Pierre Aubry)

In my opinion, I did some error or mistake: I will really appreciate any suggestion and/or correction.
Thank you very much

#11 Code_Aster usage » étudier le pièces forgées » 2014-04-02 17:56:57

caeconsulting
Replies: 1

Bonsoir a tous le monde.
Je suis en traine d' étudier des processus de forge et j'ai commencé a faire quelque approche avec le matériaux d' Anand en usant le software Adina.
Je voudrai faire mon étude avec Code Aster, donc j'ai vu que dans la section R3 il y beaucoup d' information: quelqu’un à quelque suggestion pour commencer?
J'attache une couple d' images d'un cylindre, diamètre 0,6 m et chauffé a 800°C, pressé par deux plaques qui le réduit de 50 mm chacune.
Merci a Vous
              Piero

#12 Re: Code_Aster usage » [Resolu] Traduction des fichier d' EFICAS de la vers. 9 à la 10 » 2010-06-15 10:07:39

Bien.
Ça veux dire que, pour le moment, je dois convertir le fichier à la version 10 dans Eficas.
Ciao à tous
    Piero

#13 Code_Aster usage » [Resolu] Traduction des fichier d' EFICAS de la vers. 9 à la 10 » 2010-06-15 09:38:09

caeconsulting
Replies: 2

j'ai lu la question envoyé par zoher82 le 29/7/2009, mais je n'ai trouvé pas, dans ma installation de Code-Aster, aucune référence a la traduction de la vers. 9 à la 10. (Ça existe de 8 a 9)
Est il un erreur d' installation de ma version, ou quoi d' autre?

#14 Re: Code_Aster installation » [RESOLU] problème d'installation de STA10.1 et Fedora 12 » 2010-05-25 10:24:47

courtois wrote:

Ciao,

To complete the Code_Aster built you have just to type :
cd STA10.1
../bin/as_run --make


MC

Ciao
I did what you suggested, and it worked fine.
In addition, I made a complete rebuild of Coda-Aster, but without removing the previously created /opt/aster directory.
The last setup.log is completely OK. So I keep this solution.

Now I'm fighting with some strange error (I suspect network error) in my Linux box:
- I'm able to start ASTK
- I'm able to create/modify some .comm file (running Eficas by standard ASTK command)
- and save some profile (i.e. .astk) file
but I'm not able to start a Code-Aster calculation.
The .export file is created correctly, and I verified that using as_run it starts and works fine, but ASTK is not able to send it to the server (my machine).
Again, when I try to start Stanley, nothing happens (it is not true: a new .export file is created, but Stanley doesn't start)

Again, I noted that GMSH sw, available in Code-Aster distribution, is a 32 bit executable; so it doesn't find right .i686 Nvidia opengl package (I installed x86_64 Nvidia drivers only). Also official gmsh distro has same problems.
So, I decided to recompile gmsh on my x86_64 machine:
         it seams to work properly, but I'm testing OpenCascade support for step files.
I will send a new post (in new discussion) when I will find the right solution.

Ciao and many thanks
          Piero

#15 Introduce yourself / Présentez vous » My short introduction » 2010-05-19 10:18:31

caeconsulting
Replies: 0

Ciao a tutti,
my name is Piero Cirrottola, my job is Structural Analyst [freelance] and I collaborate as professor with Politecnico di Milano. I'm enthusiast of Code-Aster, since three years.
A suggestion: it could be useful to add a new Discussion Category, for instance named "Various Forum related", were to post general kind request.
Thank you and
Ciao

        Piero

#16 Re: Code_Aster installation » [RESOLU] problème d'installation de STA10.1 et Fedora 12 » 2010-05-17 18:15:17

Ciao a tutti,
for some days I tried to run Salomè-Meca (x64 version: SALOME-MECA-2010.1-x86_64-LGPL-2.tgz); Salomè seems to work properly (I loaded some old case made three years ago with Salomé 3.1.2 and that worked well with Code-Aster 9.1), but interface with actual Code-Aster doesn't ; I'm still trying to understand if it is a problem, or if it's me that doesn't work !!!

By the way,  coming back to Code-Aster compilation problem (in my first post), I had an idea:
because I don't have a /opt/aster/public/Numeric-24.2/lib directory, instead I have a /opt/aster/public/Numeric-24.2/lib64, I created a soft-link of lib pointing to lib64 and i repeated the test you suggest:
-:
source /opt/aster/etc/codeaster/profile.sh
source /opt/aster/STA10.1/profile.sh
/opt/aster/STA10.1/asterd
>>> import Numeric
and no error occurred.
What can I do to complete my installation?
Thank you a lot, again
              Piero

#17 Re: Code_Aster installation » [RESOLU] problème d'installation de STA10.1 et Fedora 12 » 2010-05-07 17:43:12

Ciao,
I did the test you suggested; in effect I receive an error, that explains the Numeric lib isn't present.
I checked /opt/aster/STA10.1/profile.sh, as you suggested, and I found that LD_LIBRARY_PATH variable points to
"/opt/aster/public/Numeric-24.2/lib/python2.6/site-packages/Numeric".
The problem is that I don't have "/opt/aster/public/Numeric-24.2/lib" directory,
but it exist a  "/opt/aster/public/Numeric-24.2/lib64".
Perhaps could I try to change the path in profile.sh?

But, before to try this, I want to try to install Salome-meca (SALOME-MECA-2010.1-x86_64-LGPL-2.tgz).
I will say about results.
Ciao
     Piero

p.s. I'm experiencing some strange hardware error on Fedora12 (while windows XP x64 works well): can you suggest a valid choice for an other Linux distro?
Have you some info about Scientific Linux 5.1 64bit distro?

#18 Code_Aster installation » [RESOLU] problème d'installation de STA10.1 et Fedora 12 » 2010-05-04 18:59:54

caeconsulting
Replies: 9

Ciao à tous,
j'ai reçu cet erreur après l' installation de CodeAster.
Ma machine ai le suivent caractéristiques:
- cpu AMD Opteron 2222
- ram 8 GB
- Fedora 12 (Constantine)  installé et mise a jour.

Voilà l' erreur:
--------------
Build Code_Aster executable

extracting 'python.o' from libasterd.a...                               [  OK  ]
creating .../STA10.1/asterd...                                          [  OK  ]
testing executable /opt/aster/STA10.1/asterd...                         [FAILED]
Exit code : 1

Version séquentielle de Code_aster
import os : OK
import Numeric : FAILED


<F>_BUILD_ERROR    test of executables failed
------------
dans la pièce jointe il y a les fichier setup.cfg et setup.log.
Merci a vous

#19 Re: Code_Aster installation » CodeAster 9.3 Installation on Fedora 9 x64 » 2008-09-26 09:15:30

adriano wrote:

Ciao Piero,
I use fedora 9 x86_64 with code aster 9.3, I can attach my setup.cfg and my config.txt, but I use gfortran and not g77.. I hope this can be helpfull for you

ciao
Adriano

Ciao Adriano,
I will try it asap.
Just a note: I'm using gfortran too and not g77.
Again: reading your setup.cfg I noted that you put
>_install_hdf5 = False
>HOME_HDF = '/opt/aster93/public/hdf5-1.6.4'
>_install_med = False
>HOME_MED = '/opt/aster93/public/med-2.3.4'
>_install_scotch  = False
>HOME_SCOTCH = '/opt/aster93/public/scotch_4.0'
some special reason? dod you install them separately?
Ciao e grazie
        Piero

#20 Re: Code_Aster installation » CodeAster 9.3 Installation on Fedora 9 x64 » 2008-09-24 11:54:13

caeconsulting wrote:
courtois wrote:

Hi,

1. libg2c should be optionnal if you (or a lib) never use g77
2. it is certainly a problem int/long in mixing C/fortran interface. But the correct options have not been set because of the libg2c failure...

I suggest you to apply the attached patch to not search libg2c.

Please tell us if it works.
Thanks,
MC

Hello,
sorry, but I don't see any attachment in your message.
Code_Aster NEW9.3.x on Ubuntu Hardy 32 bits - GNU + Intel should be the patch?
Ciao
            Piero

Pardon
maintenant je l'ai trouvé.
Merci, je vais le prouver.
Ciao
        Piero

#21 Re: Code_Aster installation » CodeAster 9.3 Installation on Fedora 9 x64 » 2008-09-23 16:53:29

courtois wrote:

Hi,

1. libg2c should be optionnal if you (or a lib) never use g77
2. it is certainly a problem int/long in mixing C/fortran interface. But the correct options have not been set because of the libg2c failure...

I suggest you to apply the attached patch to not search libg2c.

Please tell us if it works.
Thanks,
MC

Hello,
sorry, but I don't see any attachment in your message.
Code_Aster NEW9.3.x on Ubuntu Hardy 32 bits - GNU + Intel should be the patch?
Ciao
            Piero

#22 Code_Aster installation » CodeAster 9.3 Installation on Fedora 9 x64 » 2008-09-23 11:12:26

caeconsulting
Replies: 7

Hi to everybody.
Here attached you will find a tar file containing setup.log, .cfg & .cache and variables.init files after my compilation.
I found something strange and some errors:
1) setup search for libg2c libraries (that I don't find on my machine): are they really needed?
2) error is : Error! ***Memory allocation failed for ReadGraph: xadj. Requested size: -34359618808

My machine:
hw: Fujitsu/Siemens Celsius V840 - AMD opteron 2222 - 8BG ram, 256GB hd for Fedora (2x500GB disks)
OS: Fedora 9-64bit