Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2010-12-15 20:54:43

dbpatankar
Member
From: Roorkee, Uttarakhand, India
Registered: 2010-05-22
Posts: 172

Couldn't resolve memory issue

Hi all,

I am getting the following error. I know its because of memory lack but don't know how to resolve it.

I tried changing the parameters in .export file but everytime I am getting the same error(with different numbers).

.export file(with comm and med) is attached to this post in compressed format.

System RAM = 4GB(2+2)
Processor = Intel Core 2 Duo

! Erreur lors de l'allocation dynamique. Il n'a pas t possible d'allouer         !
   !  une zone mmoire de longueur 908821588 (octets), on dpasse la limite maximum   !
   !  fixe  2146435072 (octets) et on occupe dj 1444977612 (octets).              !
   !  La dernire opration de libration mmoire a permis de rcuprer 208 (octets).

Is there any way I can overcome it on the same system? Or do I need to upgrade RAM/processor?

Any help ?

Even if you can point me towards the definition of all the parameters in .export file that will be fine.

Thanks in advance.

Last edited by dbpatankar (2010-12-15 21:11:50)


Attachments:
str7.zip, Size: 53.54 KiB, Downloads: 190

Offline

#2 2010-12-15 21:17:19

cacciatorino
Member
From: Porto Recanati, Italy
Registered: 2008-11-05
Posts: 729

Re: Couldn't resolve memory issue

Two attempts:

1) Increase the maximum memory that code_aster can handle, this can be done in the configuration file:

/opt/aster/etc/asrun (may be the path is different, I have not CA right now).

It is 2 GB per default, so it makes sense to increase it only if your oprating system is 64-bit.

2) Increase the memory assigned to the job via the ASTK gui (reading at your export file, it seems that it is 512 mb currently).

Offline

#3 2010-12-15 21:25:45

dbpatankar
Member
From: Roorkee, Uttarakhand, India
Registered: 2010-05-22
Posts: 172

Re: Couldn't resolve memory issue

cacciatorino wrote:

Two attempts:

1) Increase the maximum memory that code_aster can handle, this can be done in the configuration file:

/opt/aster/etc/asrun (may be the path is different, I have not CA right now).

It is 2 GB per default, so it makes sense to increase it only if your oprating system is 64-bit.

2) Increase the memory assigned to the job via the ASTK gui (reading at your export file, it seems that it is 512 mb currently).

Thanks for reply,

Here are the current settings in asrun file

# interactif : oui/non Choose 'non' to prohibit interactive calculation
# memory limit in interactive mode (MB)
# cpu time limit in interactive mode (hh:mm:ss)
# max proc number in interactive mode (OpenMP)
# max proc number in interactive mode (MPI)
interactif : oui
interactif_memmax : 4096
interactif_tpsmax : 999:00:00
interactif_nbpmax : 16
interactif_mpi_nbpmax : 32

I also tried increasing 512 to 1024 but that too giving the similar result.

Can you tell me what is the meaning of :
P memjob 2048000.0
A memjeveux 512.0
P tpsjob 356400
A tpmax 356400

and

P mem_aster 512.0

Offline

#4 2010-12-16 06:19:50

cacciatorino
Member
From: Porto Recanati, Italy
Registered: 2008-11-05
Posts: 729

Re: Couldn't resolve memory issue

Attached my asrun file (Aster 10.2 64 bit)

Last edited by cacciatorino (2010-12-16 07:32:40)


Attachments:
asrun, Size: 6.9 KiB, Downloads: 237

Offline

#5 2010-12-16 06:22:00

cacciatorino
Member
From: Porto Recanati, Italy
Registered: 2008-11-05
Posts: 729

Re: Couldn't resolve memory issue

And the ASTK gui of a recent problem.


Attachments:
ASTK.png, Size: 64.25 KiB, Downloads: 142

Offline

#6 2010-12-16 07:31:06

mathieu.courtois
Administrator
From: France
Registered: 2007-11-21
Posts: 1,163

Re: Couldn't resolve memory issue

Hello,

1. "memmax" parameter in etc/codeaster/asrun only defines the maximum of memory a job could request

2. in astk (or the export file), you put the memory limit really used for the job (of course it must be less than "memmax").
In the .export you joined, you have requested 2048 MB => memjob 2048*1024, memjeveux 2048/4 (32 bits)

Please do not tell me that memjob/memjeveux units are stupid sad => use astk to not manipulate them wink !

MC


Code_Aster release : last unstable on Ubuntu 16.04 64 bits - GNU Compilers

Please do not forget to tag your first post as *SOLVED* when it is!

Offline