Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2011-02-24 14:07:57

Thrall
Member
Registered: 2011-02-24
Posts: 1

Salome-Meca binary: problem with prerequis etchForSalome glibc

When I attempt to launch Salome-Meca 2010.2 (x86_64, Archlinux) (N.B: the download link at http://www.code-aster.org/V2/spip.php?article303 says 2011.1 but links to 2010.2) I get the following output:

[thrall@myhost SALOME-MECA-2010.2-LGPL-x86_64]$ ./runSalomeMeca 
python: relocation error: /home/thrall/SALOME/SALOME-MECA-2010.2-LGPL-x86_64/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
python: relocation error: /home/thrall/SALOME/SALOME-MECA-2010.2-LGPL-x86_64/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
python: relocation error: /home/thrall/SALOME/SALOME-MECA-2010.2-LGPL-x86_64/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
dirname: relocation error: /home/thrall/SALOME/SALOME-MECA-2010.2-LGPL-x86_64/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
python: relocation error: /home/thrall/SALOME/SALOME-MECA-2010.2-LGPL-x86_64/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
/bin/bash: /home/thrall/SALOME/SALOME-MECA-2010.2-LGPL-x86_64/SALOME/SALOME5/V5_1_4/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by /bin/bash)
$

Looking in "/Prerequis/etchForSalome/lib/" I find libc.so.6 is a link to "libc-2.3.6.so". Seems to me /bin/bash wants glibc 2.4 but glibc 2.3.6 is included. Any explanation or solution would be most welcome.

I have a working installation of Salome and aster in /opt but can't quite work out whether it is possible to simply add in salome-meca and the aster module at the moment (Is the source for the ASTER, PAL and EFICAS modules available yet?).

Last edited by Thrall (2011-02-24 14:09:37)

Offline

#2 2011-05-04 14:28:47

benji64
Member
From: Tarbes
Registered: 2009-11-30
Posts: 52

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

Hi,

I don't have any answer for you but exectly the same problem.
My Salome-Meca 2011.1 used to work on Kubuntu 10.10 until I've done the upgrade to 11.04 natty. Now I've got the following message :

python: relocation error: /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
Loading environnement for python 
[OK] . /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/prerequis-V5_1_5.sh
[OK] . /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/envSalome-V5_1_5.sh
[OK] . /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/envSalomeMeca.sh
dirname: /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by dirname)
[OK] . /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-SalomeMeca.sh
[OK] . /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Aster.sh
[OK] . /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Eficas.sh
python: relocation error: /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
/bin/bash: /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by /bin/bash)
/bin/bash: /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.8' not found (required by /bin/bash)
/bin/bash: /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.11' not found (required by /bin/bash)
/bin/bash: /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by /lib64/libncurses.so.5)

Note that I've run python postinstall.py after upgrade...
I tried to link the ../Prerequis/etchForSalome/lib/libc.so.6 to my local /lib32/libc.so.6 but the result is a segmentation fault :

Loading environnement for python 
[OK] . /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/prerequis-V5_1_5.sh
[OK] . /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/envSalome-V5_1_5.sh
[OK] . /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/envSalomeMeca.sh
[OK] . /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-SalomeMeca.sh
[OK] . /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Aster.sh
[OK] . /home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Eficas.sh
/usr/local/bin/SalomeMeca: line 45:  8121 Segmentation fault      python $ROOT_SALOME_MECA/postinstall/check_path.py
CHECK /home/bboniface
Searching for free port for the SALOME Naming Service: 2810 - Ok
/home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/runAppli: line 49:  8131 Segmentation fault      python -i ${KERNEL_ROOT_DIR}/bin/salome/runSalome.py
/home/bboniface/logiciel/SALOME-MECA-2011.1-x86_64/runAppli: line 52:  8132 Segmentation fault      python ${KERNEL_ROOT_DIR}/bin/salome/killSalomeWithPort.py ${NSPORT}

if someone have an idea... Thanks a lot

Offline

#3 2011-05-04 19:37:19

stuebi.thomas
Member
Registered: 2009-07-23
Posts: 50

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

Hello

Me either, I don't have a reply but the same problem. I had a running SalomeMeca2010.2 on ubuntu 10.10 and upgraded yesterday to 11.01. After having the problem with the glibc I installed the SalomeMeca 2011.1 with the same result:
I hpe someone finds a solutiion...

 

/opt/SALOME-MECA-2011.1-x86_64$ ./runSalomeMeca 
python: relocation error: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
Loading environnement for python 
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/prerequis-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/envSalome-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/envSalomeMeca.sh
dirname: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by dirname)
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-SalomeMeca.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Aster.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Eficas.sh
python: relocation error: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
/bin/bash: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by /bin/bash)
/bin/bash: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.8' not found (required by /bin/bash)
/bin/bash: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.11' not found (required by /bin/bash)
/bin/bash: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by /lib64/libncurses.so.5)
thomas@macbook:/opt/SALOME-MECA-2011.1-x86_64$

Offline

#4 2011-05-05 06:25:22

jeanpierreaubry
Guru
From: nantes (france)
Registered: 2009-03-12
Posts: 3,652

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

hello

reminds of a problem i had look here
http://www.code-aster.org/forum2/viewtopic.php?id=15130

jean pierre aubry

Last edited by jeanpierreaubry (2011-05-06 08:29:49)


consider reading my book
freely available here https://framabook.org/beginning-with-code_aster/

Offline

#5 2011-05-06 07:58:28

benji64
Member
From: Tarbes
Registered: 2009-11-30
Posts: 52

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

Hi jeanpierreaubry, thanks for the answer,

in this case it seems to not works (libc.so.6). it gives a segmentation fault.

Anyway I installed Salome5 using the InstallWizard_5.1.5_Debian_4.0_64bit (not the 5.0 witch does not work, or maybe with the solution of jeanpierreaubry) using th tuto here.
In a second time I installed/compiled Code_Aster using this tuto, easily.

Waiting for the next SalomeMeca... or not.

Offline

#6 2011-05-06 08:35:09

jeanpierreaubry
Guru
From: nantes (france)
Registered: 2009-03-12
Posts: 3,652

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

once you get used to work directly with Aster, thru Astk or not,
and you have a working Salome
Salome-Meca is not needed any more


consider reading my book
freely available here https://framabook.org/beginning-with-code_aster/

Offline

#7 2011-05-06 10:20:43

stuebi.thomas
Member
Registered: 2009-07-23
Posts: 50

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

Of course but the Aster Module in SalomeMeca is an very practical tool...

Offline

#8 2011-05-06 21:36:31

benji64
Member
From: Tarbes
Registered: 2009-11-30
Posts: 52

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

is there a way to add the aster module in a salome installation? I meen like the PYHELLO exemple module... as the pilotage en other stuff are also installed when you compile aster...

Offline

#9 2011-05-15 21:52:00

RPSchmitz
Member
From: Brookfield, WI
Registered: 2011-03-01
Posts: 12
Website

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

I'm having exactly the same problem as benji64 and stuebi.thomas and look forward to a solution soon.  Else I may need to revert to Ubuntu 10.10.  Ugh. sad

python: relocation error: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
Loading environnement for python
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/prerequis-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/envSalome-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/envSalomeMeca.sh
dirname: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by dirname)
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-SalomeMeca.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Aster.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Eficas.sh
python: relocation error: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
/bin/bash: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by /bin/bash)
/bin/bash: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.8' not found (required by /bin/bash)
/bin/bash: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.11' not found (required by /bin/bash)
/bin/bash: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by /lib64/libncurses.so.5)

Thanks.

Bob


Salome-Meca 2011.1 + Code-Aster STA10.3 on Ubuntu 10.10 (64bit) running in Oracle VM VirtualBox under Windows 7 Professional

Offline

#10 2011-05-17 10:59:11

baguilo
Member
Registered: 2011-03-19
Posts: 4

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

I have the same problem.

RPSchmitz wrote:

I'm having exactly the same problem as benji64 and stuebi.thomas and look forward to a solution soon.  Else I may need to revert to Ubuntu 10.10.  Ugh. sad

python: relocation error: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
Loading environnement for python
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/prerequis-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/envSalome-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/envSalomeMeca.sh
dirname: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by dirname)
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-SalomeMeca.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Aster.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Eficas.sh
python: relocation error: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
/bin/bash: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by /bin/bash)
/bin/bash: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.8' not found (required by /bin/bash)
/bin/bash: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.11' not found (required by /bin/bash)
/bin/bash: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by /lib64/libncurses.so.5)

Thanks.

Bob

Offline

#11 2011-05-17 11:09:51

jeanpierreaubry
Guru
From: nantes (france)
Registered: 2009-03-12
Posts: 3,652

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

hello

you should try the workaround described here
http://www.code-aster.org/forum2/viewtopic.php?id=15078
which i did and it works

jean pierre aubry


consider reading my book
freely available here https://framabook.org/beginning-with-code_aster/

Offline

#12 2011-05-18 16:22:08

RPSchmitz
Member
From: Brookfield, WI
Registered: 2011-03-01
Posts: 12
Website

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

jeanpierreaubry wrote:

hello

you should try the workaround described here
http://www.code-aster.org/forum2/viewtopic.php?id=15078
which i did and it works

jean pierre aubry

Thanks for the suggestion.  I took a look at this and related topics from this post I tried a similar solution. 
It seems to all boil down to relating to old GLIBC libraries.  Here's what I found.  Following a
similar solution as reference above I did the following:

rm  libc.so.6 rm ld-linux-x86-64.so.2

ln -s /usr/lib64/x86_64-linux-gnu/libc.so libc.so.6

ln -s /usr/lib64/x86_64-linux-gnu/libc.so ld-linux-x86-64.so.2

This resulted in the following terminal output:

rps@rps-VirtualBox:/opt/SALOME-MECA-2011.1-x86_64$ ./runSalomeMeca
python: error while loading shared libraries: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: invalid ELF header
Loading environnement for python
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/prerequis-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/envSalome-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/envSalomeMeca.sh
dirname: error while loading shared libraries: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: invalid ELF header
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-SalomeMeca.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Aster.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Eficas.sh
python: error while loading shared libraries: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: invalid ELF header
/bin/bash: error while loading shared libraries: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: invalid ELF header
rps@rps-VirtualBox:/opt/SALOME-MECA-2011.1-x86_64$

A similar GLIBC library issue brought up in Ubutu Forum:

http://ubuntuforums.org/showthread.php? … es+missing

Suggestion from Morgan's Blog for MATLAB on Ubuntu 11.04

http://morganbye.net/blog/2011/05/matlab-ubuntu-1104

sudo ln -s /lib64/x86_64-linux-gnu/libc-2.13.so /lib64/libc.so.6

Trying this results in the following terminal output:

rps@rps-VirtualBox:/opt/SALOME-MECA-2011.1-x86_64$ ./runSalomeMeca
Loading environnement for python
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/prerequis-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/envSalome-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/envSalomeMeca.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-SalomeMeca.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Aster.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Eficas.sh
./runSalomeMeca: line 45:  1771 Segmentation fault      python $ROOT_SALOME_MECA/postinstall/check_path.py
CHECK /home/rps
Searching for free port for the SALOME Naming Service: 2810 - Ok
/opt/SALOME-MECA-2011.1-x86_64/runAppli: line 49:  1781 Segmentation fault      python -i ${KERNEL_ROOT_DIR}/bin/salome/runSalome.py
/opt/SALOME-MECA-2011.1-x86_64/runAppli: line 52:  1782 Segmentation fault      python ${KERNEL_ROOT_DIR}/bin/salome/killSalomeWithPort.py
${NSPORT}
rps@rps-VirtualBox:/opt/SALOME-MECA-2011.1-x86_64$

I know very, very little about this operating system but, I think we're getting closer to a solution.

Any more suggestions?  Thanks.

Bob


Salome-Meca 2011.1 + Code-Aster STA10.3 on Ubuntu 10.10 (64bit) running in Oracle VM VirtualBox under Windows 7 Professional

Offline

#13 2011-05-19 19:00:36

stuebi.thomas
Member
Registered: 2009-07-23
Posts: 50

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

Hello

I also got there...

Loading environnement for python 
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/prerequis-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/envSalome-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/envSalomeMeca.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-SalomeMeca.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Aster.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Eficas.sh
./runSalomeMeca: line 45:  2520 Segmentation fault      python $ROOT_SALOME_MECA/postinstall/check_path.py
CHECK /home/thomas
Searching for free port for the SALOME Naming Service: 2810 - Ok
/opt/SALOME-MECA-2011.1-x86_64/runAppli: line 49:  2530 Segmentation fault      python -i ${KERNEL_ROOT_DIR}/bin/salome/runSalome.py
/opt/SALOME-MECA-2011.1-x86_64/runAppli: line 52:  2531 Segmentation fault      python ${KERNEL_ROOT_DIR}/bin/salome/killSalomeWithPort.py ${NSPORT}

Additional information:
In the meantime I found out, that after sourcing the terminal shows up segmentation faults.
-> source envSalome.sh
-> cd $KERNEL_ROOT_DIR leads to the right directory but if I now want to list with ls I get the segmentation fault!

Maybe this has some importance???

Last edited by stuebi.thomas (2011-05-20 13:18:33)

Offline

#14 2011-05-21 16:16:23

RPSchmitz
Member
From: Brookfield, WI
Registered: 2011-03-01
Posts: 12
Website

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

stuebi.thomas wrote:

Hello

I also got there...

Loading environnement for python 
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/prerequis-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/envSalome-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/envSalomeMeca.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-SalomeMeca.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Aster.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Eficas.sh
./runSalomeMeca: line 45:  2520 Segmentation fault      python $ROOT_SALOME_MECA/postinstall/check_path.py
CHECK /home/thomas
Searching for free port for the SALOME Naming Service: 2810 - Ok
/opt/SALOME-MECA-2011.1-x86_64/runAppli: line 49:  2530 Segmentation fault      python -i ${KERNEL_ROOT_DIR}/bin/salome/runSalome.py
/opt/SALOME-MECA-2011.1-x86_64/runAppli: line 52:  2531 Segmentation fault      python ${KERNEL_ROOT_DIR}/bin/salome/killSalomeWithPort.py ${NSPORT}

Additional information:
In the meantime I found out, that after sourcing the terminal shows up segmentation faults.
-> source envSalome.sh
-> cd $KERNEL_ROOT_DIR leads to the right directory but if I now want to list with ls I get the segmentation fault!

Maybe this has some importance???

Did you use source envSalome.sh or envSalomeMeca.sh?

Here's what I got using envSalomeMeca.sh:

rps@rps-VirtualBox:/opt/SALOME-MECA-2011.1-x86_64$ source envSalomeMeca.sh

python: relocation error: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: symbol _dl_out_of_memory, version GLIBC_PRIVATE not defined in file ld-linux-x86-64.so.2 with link time reference
Loading environnement for python
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/prerequis-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/envSalome-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/envSalomeMeca.sh
dirname: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by dirname)
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-SalomeMeca.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Aster.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Eficas.sh
rps@rps-VirtualBox:/opt/SALOME-MECA-2011.1-x86_64$

rps@rps-VirtualBox:/opt/SALOME-MECA-2011.1-x86_64$ cd $KERNEL_ROOT_DIR
rps@rps-VirtualBox:/opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/KERNEL_V5_1_5$ ls

ls: /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/../Prerequis/etchForSalome/lib/libc.so.6: version `GLIBC_2.4' not found (required by /lib64/libsepol.so.1)

rps@rps-VirtualBox:/opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/KERNEL_V5_1_5$


Bob


Salome-Meca 2011.1 + Code-Aster STA10.3 on Ubuntu 10.10 (64bit) running in Oracle VM VirtualBox under Windows 7 Professional

Offline

#15 2011-05-22 10:36:51

stuebi.thomas
Member
Registered: 2009-07-23
Posts: 50

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

I used envSalomeMeca.sh and get

Loading environnement for python 
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/prerequis-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME/SALOME5/V5_1_5/envSalome-V5_1_5.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/envSalomeMeca.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-SalomeMeca.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Aster.sh
[OK] . /opt/SALOME-MECA-2011.1-x86_64/SALOME-MECA/V5_1_5/prerequis-Eficas.sh
CHECK /home/thomas
Searching for free port for the SALOME Naming Service: 2810 - Ok
/opt/SALOME-MECA-2011.1-x86_64/runAppli: line 49:  3122 Segmentation fault      python -i ${KERNEL_ROOT_DIR}/bin/salome/runSalome.py
/opt/SALOME-MECA-2011.1-x86_64/runAppli: line 52:  3123 Segmentation fault      python ${KERNEL_ROOT_DIR}/bin/salome/killSalomeWithPort.py ${NSPORT}

Offline

#16 2011-05-29 22:37:24

Marco
Member
Registered: 2011-05-29
Posts: 2

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

i have the same problem, i find a salome working in kpackagekit (without aster)

Offline

#17 2011-06-06 16:32:40

Cindy
Member
Registered: 2011-04-12
Posts: 35

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

Hello,

I have the same problem to launch Salome-Meca 2010.2 (Universal 32bits version) on Ubuntu 11.04 Linux OS. Please see the link installation OK but runSalomeMeca cannot run for the error messages. Any idea to solve the problem? Thanks!

Merci beaucoup!

Cindy

Last edited by Cindy (2011-06-06 16:33:43)

Offline

#18 2011-06-06 16:46:28

jeanpierreaubry
Guru
From: nantes (france)
Registered: 2009-03-12
Posts: 3,652

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

Cindy wrote:

Hello,

I have the same problem to launch Salome-Meca 2010.2 (Universal 32bits version) on Ubuntu 11.04 Linux OS. Please see the link installation OK but runSalomeMeca cannot run for the error messages. Any idea to solve the problem? Thanks!

Merci beaucoup!

Cindy

did you try my suggestion in post #11 just above!

jean pierre aubry


consider reading my book
freely available here https://framabook.org/beginning-with-code_aster/

Offline

#19 2011-06-07 02:49:45

Cindy
Member
Registered: 2011-04-12
Posts: 35

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

Hello jeanpierreaubry,

Thanks for the reply. I tried it and libc.so.6 problem is gone. But now ./runSalomeMeca aborts with the following segmentation faults. I do not know if the problem can be fixed to make the binary working.

cindy@cindy-Evo-D310:~$ /opt/SALOME-MECA-2010.2-LGPL-i386/runSalomeMeca
/opt/SALOME-MECA-2010.2-LGPL-i386/runSalomeMeca: line 45:  2586 Segmentation fault      python $ROOT_SALOME_MECA/postinstall/check_path.py
CHECK /home/cindy
Searching for free port for the SALOME Naming Service: 2810 - Ok
/opt/SALOME-MECA-2010.2-LGPL-i386/runAppli: line 49:  2596 Segmentation fault      python -i ${KERNEL_ROOT_DIR}/bin/salome/runSalome.py
/opt/SALOME-MECA-2010.2-LGPL-i386/runAppli: line 52:  2597 Segmentation fault      python ${KERNEL_ROOT_DIR}/bin/salome/killSalomeWithPort.py ${NSPORT}

Merci beaucoup.

Cindy

Offline

#20 2011-06-07 21:42:28

Marco
Member
Registered: 2011-05-29
Posts: 2

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

i have the same problem

Offline

#21 2011-06-14 21:25:28

assire
Administrator
From: Paris
Registered: 2007-11-21
Posts: 225

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

Yes, we know that the "debianForSalome" package doesn't work with recent GLIBC library.
Debian unstable or latest Ubuntu are in this case.

We work on this issue.

Regards

Aimery Assire

Offline

#22 2011-09-07 23:34:24

titi77
Member
From: Lyon
Registered: 2011-09-07
Posts: 2

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

Hello, everybody
To get salome-meca work on ubuntu natty, you have to edit the file: "{SALOME_DIR}/appli/env.d/envProducts.sh"
and change the line 34


export LD_LIBRARY_PATH=/lib64:${DEBIANFORSALOME}/lib:${LD_LIBRARY_PATH}

to

export LD_LIBRARY_PATH=/lib64:/lib/x86_64-linux-gnu:${DEBIANFORSALOME}/lib:${LD_LIBRARY_PATH}

Hope it will help.
Let use it!

Best regards

Offline

#23 2011-10-07 16:20:56

GillesDavid
Member
Registered: 2011-10-07
Posts: 1

Re: Salome-Meca binary: problem with prerequis etchForSalome glibc

Hello Code_Aster users,

Please try to follow my instructions here : http://www.salome-platform.org/forum/forum_9/322811199
There is a last process in this message (end of the thread): http://www.salome-platform.org/forum/fo … /198828544

Regards,
Gilles

Offline