Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2016-12-01 08:33:21

konyaro
Member
From: Genève
Registered: 2016-04-02
Posts: 262

[SOLVED] POURSUITE problem

Hello,
I’m facing a problem with the POURSUITE command. I simplified my example in order to make it easy to understand. I rotate a mesh made of C_PLAN and link to a single node with POU_D_T_GD. If I solve the simulation within a single comm file it runs well. But if I try to split it in 2 comm files with the POURSUITE command, I get the following error:

   !--------------------------------------------------------------!
   ! <EXCEPTION> <DVP_1>                                          !
   !                                                              !
   ! Erreur de programmation.                                     !
   !                                                              !
   ! Condition non respectée:                                     !
   !     lgcata.eq.zi(jceld-1+zi(jceld-1+4+ca_igr_)+3)            !
   ! Fichier jevech.F90, ligne 150                                !
   !                                                              !
   ! --------------------------------------------                 !
   ! Contexte du message :                                        !
   !    Option         : RIGI_MECA_TANG                           !
   !    Type d'élément : MECA_POU_D_T_GD                          !
   !    Maillage       : mesh0                                    !
   !    Maille         : M1                                       !
   !    Type de maille : SEG2                                     !
   !    Cette maille appartient aux groupes de mailles suivants : !
   !       Poutres tout                                           !
   !    Position du centre de gravité de la maille :              !
   !       x=-0.835526 y=0.223878 z=0.000000                      !
   !                                                              !
   !                                                              !
   !                                                              !
   ! Il y a probablement une erreur dans la programmation.        !
   ! Veuillez contacter votre assistance technique.               !
   !--------------------------------------------------------------!

If I remove the POU_D_T_GD the POURSUITE works well but it is now what I want...
I guess it is a bug but I’m not sure. I attached the comm and mess files.

Thank you for your help,

K.

Last edited by konyaro (2016-12-08 06:26:43)


Attachments:
Pb_poursuite.zip, Size: 42.59 KiB, Downloads: 261

失敗は成功のもと (L'échec est la base de la réussite)

Offline

#2 2016-12-01 09:32:16

RichardS
Member
From: Munich, Germany
Registered: 2010-09-28
Posts: 551
Website

Re: [SOLVED] POURSUITE problem

Hello konyaro,
I agree, this definitely looks like a bug. Did you already report it on the bitbucket repo?

Did you try to run the analysis without PAR_LOT='NON', it seems it is not required in your case.

Best,
Richard


Richard Szoeke-Schuller
Product Management
www.simscale.com
We are hiring! https://www.simscale.com/jobs/

Offline

#3 2016-12-01 10:39:52

konyaro
Member
From: Genève
Registered: 2016-04-02
Posts: 262

Re: [SOLVED] POURSUITE problem

Hello Richard,
thank you for your answer. I get the same error with PAR_LOT='OUI'. I'm going to try to report it on bitbucket.

Regards,
K.

Last edited by konyaro (2016-12-08 06:25:31)


失敗は成功のもと (L'échec est la base de la réussite)

Offline

#4 2016-12-01 22:25:14

AsterO'dactyle
Administrator
Registered: 2007-11-29
Posts: 386

Re: [SOLVED] POURSUITE problem

Hello,

yes, it's a bug.

Thank you !


Code_Asterの開発者

Offline

#5 2016-12-08 06:26:25

konyaro
Member
From: Genève
Registered: 2016-04-02
Posts: 262

Re: [SOLVED] POURSUITE problem

The bug has been submitted and corrected:

https://bitbucket.org/code_aster/codeas … te-problem

Thank you for your promptness.


失敗は成功のもと (L'échec est la base de la réussite)

Offline