Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2017-11-16 14:38:44

dbpatankar
Member
From: Roorkee, Uttarakhand, India
Registered: 2010-05-22
Posts: 172

OpenSUSE Tumbleweed : Error during salome launch

Hi,

I am trying to get Salome-Meca-2017.0.2 working on OpenSUSE.

The installation went without echoing any error (Though the step 'adjusting the parameters in SalomeApp.xml' took a noticeably long time).

But when I try to launch the application, here is what happens :

digvijay@localhost:~/salome_meca/appli_V2017.0.2> ./salome 
runSalome running on localhost.localdomain
Error when trying to access active network connections.
Traceback (most recent call last):
  File "/home/digvijay/salome_meca/appli_V2017.0.2/bin/salome/PortManager.py", line 111, in __isNetworkConnectionActiveOnPort
    p = Popen(cmd, stdout=PIPE, stderr=STDOUT)
  File "/home/digvijay/salome_meca/V2017.0.2/prerequisites/Python-2710/lib/python2.7/subprocess.py", line 710, in __init__
    errread, errwrite)
  File "/home/digvijay/salome_meca/V2017.0.2/prerequisites/Python-2710/lib/python2.7/subprocess.py", line 1335, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
Searching for a free port for naming service: 2820 - OK
Searching Naming Service ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++Failed to narrow the root naming context
Traceback (most recent call last):
  File "/home/digvijay/salome_meca/appli_V2017.0.2/bin/salome/runSalome.py", line 625, in useSalome
    clt = startSalome(args, modules_list, modules_root_dir)
  File "/home/digvijay/salome_meca/appli_V2017.0.2/bin/salome/runSalome.py", line 422, in startSalome
    clt=orbmodule.client(args)
  File "/home/digvijay/salome_meca/V2017.0.2/modules/KERNEL_V8_3_0/bin/salome/orbmodule.py", line 47, in __init__
    self.initNS(args or {})
  File "/home/digvijay/salome_meca/V2017.0.2/modules/KERNEL_V8_3_0/bin/salome/orbmodule.py", line 86, in initNS
    sys.exit(1)
SystemExit: 1


--- Error during Salome launch ---

Any idea about whats happening here?

Offline

#2 2017-12-15 11:33:47

mathieu.courtois
Administrator
From: France
Registered: 2007-11-21
Posts: 1,163

Re: OpenSUSE Tumbleweed : Error during salome launch

Hello,

Usually this proble appears when Salome ORB can not connect to its server (locally).
Ensure that you can resolve your hostname: ping $(hostname)

If not, you should have to add your hostname in /etc/hosts on the same line as localhost (ip 127.0.0.1).
=> check that ping now responds

Else you may try to comment ipv6 lines in /etc/hosts...

MC


Code_Aster release : last unstable on Ubuntu 16.04 64 bits - GNU Compilers

Please do not forget to tag your first post as *SOLVED* when it is!

Offline

#3 2018-01-08 20:57:55

aigars
Member
Registered: 2016-10-22
Posts: 7

Re: OpenSUSE Tumbleweed : Error during salome launch

Hi!

I am using Arch linux and had the same problem - " Error when trying to access active network connections".

Everything was ok with the hostname, but I solved the issue installing net-tools package (for netstat) and everyting is OK now.

Regards
Aigars

Offline

#4 2018-10-18 13:27:23

RichIndesteege
Member
Registered: 2016-01-08
Posts: 2

Re: OpenSUSE Tumbleweed : Error during salome launch

Hi,
Installing Salome-meca 2017 and 2018 on Opensuse leap 15.
I had the same issue on OpenSuSe leap 15.0, however net-tools was installed; I installed net-tools-deprecated and issue was solved!

Reagrds,
Richard

Offline