Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2018-01-17 14:24:07

souren
Member
Registered: 2016-10-26
Posts: 64

[SOLVED]astk error message

Hi everyone,

Here is a modification of the same question with more details, hopefully this time someone can help with the issue.

I could finally install the development version (testing) of the code and it seems to be working just fine.
However the problem with astk persists and when I run astk on terminal (my OS is ubuntu 16.04 LTS) I get the following message:

<ERROR 003> as_info : Exit code = -999
couldn't execute "/usr/bin/as_run": no such file or directory
====== end of message ======
<INFO> Ready
<INFO> Previous configuration file saved as config_serveurs.old
<INFO> Update option classe. Authorized values : 
<INFO> Updating AGLA configuration...
<INFO> The development machine - isn't in
the available servers list.

I had a look at the document U1.04.00 and it seems I have some problem with the configuration of astk, so it can not connect to the reference servers.
On page 23 of the document it mentions that the file $HOME/.astkrc/prefs contains two necessary information in order to contact the reference servers, 1. the complete name of the server (I assume it means the name of my own machine, right?), 2. the user login.
Here is the content of the $HOME/.astkrc/prefs file on my system:

 1 # AUTOMATICALLY GENERATED
  2 # You can edit this file but comments are lost when it is saved by astk.
  3 astkrc_version : 1.1
  4 #
  5 nom_user : _VIDE
  6 email : _VIDE
  7 org : _VIDE
  8 #def_vers : testing
  9 def_vers : DEV
 10 #xterm : /usr/bin/gnome-terminal --display=@D --command=@E
 11 xterm : /usr/bin/xterm -e @E
 12 #editeur : /usr/bin/gedit --display=@D
 13 nb_reman : 6
 14 langue : ENG
 15 dbglevel : 3
 16 freq_actu : 3
 17 nb_ligne : 20
 18 flag_maj : 01.13.01
 19 isdhcp : 0
 20 ipdhcp : _VIDE
 21 nom_domaine : _VIDE
 22 bip : _VIDE
 23 remote_copy_protocol : SCP
 24 remote_shell_protocol : SSH
 25 couleur : _VIDE
 26 font_main : helvetica 10
 27 font_fixe : courier 10
 28 font_bsf : helvetica 10
 29 Geom_astk : _VIDE
 30 Geom_asjob : _VIDE
 31 Geom_bsf : _VIDE
 32 Geom_rex : _VIDE
 33 Geom_log : _VIDE
 34 browser : _VIDE
 35 theme : _VIDE
 36 forced_display : _VIDE
 37 listul : default
 38 user_listul : _VIDE
 39 vers : DEV:$HOME/dev/codeaster/install/std/share/aster
 40 #
 41 # Following values are not used by codeaster-gui (astk)
 42 # but may be useful to as_run.
 43 # (this replace the old ~/.astkrc/config file)

I assume line 5 refers to name of the server, am I right? what about the user login? where is that defined?
But the point about this file is, when I compared it with the same file on another machine where astk functions normally without a problem the contents of  $HOME/.astkrc/prefs files are exactly the same, so the question is : is the error message shown at the beginning of this post relevant to the content of $HOME/.astkrc/prefs? If not why the document U1.04.00 says that those two important information should be defined in $HOME/.astkrc/prefs?
Anyhow here is the contents of the file ~/.astkrc/log.astk which may give you more insight to the issue:

<INFO> Session started : 06/02/2018 - 10:24:16 (process id 14135)
<INFO> ASTK version 1.13.1
<INFO> Current theme:
<INFO> Domain name not defined for localhost. Remote machines couldn't contact localhost. Fill the domain name through Configuration/Preferences/Network menu.
<INFO> Full name of localhost : moosavi-HP-Z800-Workstation
<INFO> The DISPLAY above is without domain name. It's possible that remote machines could'nt open windows.
<INFO> Display applications to moosavi-HP-Z800-Workstation:0
<INFO> Command ps used : ps
<INFO> Check step completed : 0 error(s).
<INFO> Debug mode actived (level 3)
<INFO> Get informations about the configuration of moosavi-HP-Z800-Workstation. Please wait...
<INFO> External command on moosavi-HP-Z800-Workstation (server id : -1) :
   /usr/bin/as_run --proxy --info --schema=asrun.plugins.default.info /tmp/astk_moosavi/.info_export_1517909058266  --log_progress=/home/moosavi/.astkrc/logprogress
<INFO> Process number : couldn't execute "/usr/bin/as_run": no such file or directory
<DEBUG> Opt_conf : serv_conf = moosavi-HP-Z800-Workstation
<INFO> Session ended : 06/02/2018 - 10:58:54
EXIT CODE : 0

would someone please help me understand the issue so hopefully I can solve my problem with astk please?


Thanks,
Souren

Last edited by souren (2018-03-01 14:26:58)

Offline

#2 2018-03-01 14:26:37

souren
Member
Registered: 2016-10-26
Posts: 64

Re: [SOLVED]astk error message

Here is an answer to the problem above;

There is no problem with configuration of astk whatsoever, the problem was that, as it can be seen in the error message

couldn't execute "/usr/bin/as_run": no such file or directory

there was an astk file in the directory /usr/bin/ (I have no idea how it ended up there), so every time I launched astk, my machine was looking for as_run to launch (apparently astk is run by as_run) and since there was no as_run in the directory /usr/bin/ I was getting the above mentioned error message. Deleting astk in /usr/bin/ was the remedy.
By the way thanks for helps and tips on the forum I resolved the problem.
A special thanks to Mr. Aubry for his follow up and remarks

Cheers

Offline

Board footer