Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2018-02-07 18:01:33

Registered: 2017-11-21
Posts: 6

Aster-Study Module Error


I'm getting an error when I try to open the Aster-Study module, the error reads "failed to activate module AsterStudy"

Any ideas?

Also, upon installation I receive these errors in the terminal

Warning: the directory /home/USERNAME/bin is in a path variable but doesn't exist
Warning: the directory /home/USERNAME/.local/bin is in a path variable but doesn't exist
Warning: the directory /snap/bin is in a path variable but doesn't exist

Are they related to the aster study module error?

Edit: Update, I received this error when I used the shortcut to run the program on the desktop, when I used the command ./salome in the /salome_meca/appli_V2017.0.2  directory the aster study module opens w/o the error.

Something perhaps to note.

Are the warnings something I should be concerned about?


Last edited by ddfriel101 (2018-02-07 18:08:29)


#2 2018-02-08 10:31:03

Thomas DE SOZA
From: EDF
Registered: 2007-11-23
Posts: 3,066

Re: Aster-Study Module Error


The warnings emitted by the installation process may be safely ignored.

Regarding the different behaviours between the shortcut and the "salome" executable in a terminal, this is quite strange. Thanks for the feedback though. We'll try to look into it.



#3 2018-07-26 16:51:30

From: Chengdu, China
Registered: 2016-01-07
Posts: 47

Re: Aster-Study Module Error

I also got this error  and there was missing python-dateutil. some times even if it is already installed it causes problem. I unistalled and again then installed using following command.

pip uninstall python-dateutil
pip install python-dateutil

after that there was an error
matplotlib requires pyparsing

Then install pyparsing.

pip install pyparsing

It worked for me

Yours Sincerely,

Prafulla Malla


#4 2020-06-30 15:53:02

Liu Shibo
Registered: 2020-06-30
Posts: 2

Re: Aster-Study Module Error

Hi Praful,

Thank you. Your method solved the problem for me.
Hope others also get helped by your solution.