Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2018-05-23 11:28:35

dbpatankar
Member
From: Roorkee, Uttarakhand, India
Registered: 2010-05-22
Posts: 164

Fedora 28 libbz2.so error during installation

Hi,

I just installed a fresh copy of fedora 28. Now when I try to install Salome_Meca, I get error which is

salome_meca post-installation ...
python: error while loading shared libraries: libbz2.so.1.0: cannot open shared object file: No such file or directory

I have already seen the post htt-ps://www.code-aster.org/forum2/viewtopic.php?id=22828 which suggests that the issue is resolved. Yet I get this error. I know that libbz2.so exists in my library path.
I am trying to install a freshly downloaded Salome_Meca file (Salome-Meca-2017.0.2-LGPL-2.tgz).

Can anyone suggest a workaround?

Offline

#2 2019-01-10 11:49:50

ypkalariya
Member
Registered: 2018-01-31
Posts: 7

Re: Fedora 28 libbz2.so error during installation

You have to create a symbolic link for it.
I was getting same error on CentOS and creating link worked for me.

ln -s /usr/lib64/libbz2.so.1.0.6  /usr/lib64/libbz2.so.1.0

Offline

Board footer