Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2018-11-09 10:33:28

knightwhosayni
Member
From: Poznań, Poland
Registered: 2009-01-11
Posts: 6

DYNA_VIBRA crashed without giving a reason

I'm trying to conduct a dyna_vibra simulation. It works well on other machines (identical) but failes on one, not giving a reason beyond:

 simshell = CALC_CHAMP(RESULTAT=dyna,
                        GROUP_MA=('shell', ),
                        MODELE=orgmodel,
                        PRECISION=1.E-06,
                        CONTRAINTE=('SIGM_ELNO', ),
                        DEFORMATION=('EPSI_ELNO', ),
                        INFO=1,
                        CRITERE='RELATIF',)

.
.
.


Ouverture en écriture du fichier ./vola.4
  Le processeur #1 a émis un message d'erreur.
  Le processeur #2 a émis un message d'erreur.
  Le processeur #3 a émis un message d'erreur.
  On demande au processeur #1 de s'arrêter ou de lever une exception.
  On demande au processeur #2 de s'arrêter ou de lever une exception.
  On demande au processeur #3 de s'arrêter ou de lever une exception.

   !------------------------------------------------------------------------!
   ! <EXCEPTION> <APPELMPI_95>                                              !
   !                                                                        !
   !     Tous les processeurs sont synchronisés.                            !
   !     Suite à une erreur sur un processeur, l'exécution est interrompue. !
   !------------------------------------------------------------------------!



 Critère de destruction du fichier (1.00 %) associé à la base VOLATILE dépassé 15.56 %
 Nombre d'enregistrements utilisés : 49803
 Volume disque occupé              : 38909 Mo.
 Nombre maximum d'enregistrements  : 320000


  Ouverture en écriture du fichier ./vola.1

  Validation du concept 'simshell'.

  # ------------------------------------------------------------------------------------------
  # Commande No :  0059            Concept de type : -
  # ------------------------------------------------------------------------------------------
  FIN(INFO_RESU='OUI',
      RETASSAGE='NON',
      FORMAT_HDF='NON',
      PROC0='OUI',)

   
   !----------------------------------------------------------------!
   ! <A> <APPELMPI_2>                                               !
   !                                                                !
   !   13 alarmes ont été émises sur le processeur #1.              !
   !   13 alarmes ont été émises sur le processeur #2.              !
   !   13 alarmes ont été émises sur le processeur #3.              !
   !                                                                !
   !                                                                !
   ! Ceci est une alarme. Si vous ne comprenez pas le sens de cette !
   ! alarme, vous pouvez obtenir des résultats inattendus !         !
   !----------------------------------------------------------------!

I thought it was something wrong with the computer but when i moved disks to another identical machine it still happens - it always failes at exactly the same point which is strange. It will go through if I change number of steps from 25 to 1. Did this simulation hundreds of times before and never had a problem.

Could it be a problem with saving/reading ./vola.4 file? Or maybe with openmpi or other library? CA installation is copied from other machine where it works well.
I will be grateful for any ideas.

Offline

Board footer