Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2019-03-21 12:55:26

chenghui62000
Member
From: Norway
Registered: 2018-06-19
Posts: 79

Slow running with DYNA_NON_LINE

hi,
I am trying to do a simulation for a net plane. But it needs a lot of time to do the simulation. I just put the gravity and boundary condition in the setting up.

Here are the comm file and mesh file.
could you please help me to check if there is anything wrong in the setting?

Best regards,
Hui Cheng


Attachments:
g2.tar.gz, Size: 43.55 KiB, Downloads: 75

Offline

#2 2019-03-21 14:44:42

chenghui62000
Member
From: Norway
Registered: 2018-06-19
Posts: 79

Re: Slow running with DYNA_NON_LINE

Is that because of the mesh file? I did not find any fault in the comm file

Offline

#3 2019-03-21 15:27:09

jeanpierreaubry
Guru
From: nantes (france)
Registered: 2009-03-12
Posts: 3,569

Re: Slow running with DYNA_NON_LINE

hello

lets do a bit of pedagogy
have a look at the convergence table in the .mess file
probably the answer is in it

jean pierre aubry

Offline

#4 2019-03-21 21:32:14

chenghui62000
Member
From: Norway
Registered: 2018-06-19
Posts: 79

Re: Slow running with DYNA_NON_LINE

Hi, This is the error message, traslated from Google.

1593/5000
CR initialization phase
   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
   ! <S> User exception raised but not intercepted. !
   ! The bases are closed. !
   ! Exception type: NonConvergenceError!
   ! !
   ! Stop because of lack of convergence with the number of iterations required!
   ! in Newton's nonlinear algorithm. !
   ! The global database is saved. It contains the archived steps before!
   ! shutdown. !
   ! !
   ! Tips:!
   ! - Increase ITER_GLOB_MAXI. !
   ! - Update the tangent matrix more often. !
   ! - Refine your temporal discretization. !
   ! - Try to enable event management (time step cut by!
   ! example) in the command DEFI_LIST_INST. !
   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
end CR initialization phase

>> JDC.py: END REPORT
EXECUTION_CODE_ASTER_EXIT_26794 = 1

I have tried to increase the ITER_GLOB_MAXI upto 10000, but it still did not give any result.
for the tangent matrix, I and temporal discretization, I do not know how to change this.

Offline

#5 2019-03-21 21:33:59

chenghui62000
Member
From: Norway
Registered: 2018-06-19
Posts: 79

Re: Slow running with DYNA_NON_LINE

By the way, a new error came when I change the ITER_GLOB_MAXI upto 10000.

>> JDC.py : DEBUT RAPPORT
CR phase d'initialisation
   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
   ! <S> Exception utilisateur levee mais pas interceptee. !
   ! Les bases sont fermees.                               !
   ! Type de l'exception : NonConvergenceError             !
   ! [('?', (), (), ())]                                   !
   !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
fin CR phase d'initialisation

but this time, no advice at the end.
best regards,
hui Cheng

Offline

#6 2019-03-22 05:10:46

GPSalachs
Member
Registered: 2018-03-10
Posts: 119

Re: Slow running with DYNA_NON_LINE

Just for information, if you don't stop the calculation in the event of no convergence,what error does it give?!

Offline