Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2019-10-07 12:24:05

IV_CoAs
Member
From: Tampere
Registered: 2013-07-12
Posts: 48

[SOLVED] Aster 14.4 Parallel compiling

Hello,

I have compiled Aster 14.4 full package sequential with success, but with parallel I faced problem, which didn't exist when compiling 13.6 parallel.

Below copy from terminal:

"
Checking measure of VmSize during MPI_Init : failed (memory consumption can not be estimated during the calculation)
Checking for library pthread             : yes
Checking for library dl                  : yes
Checking for library util                : yes
Checking for program 'python'            : /usr/bin/python3
Checking for python version >= 3.5.0     : 3.5.2
python-config                            : /usr/bin/python3-config
Asking python-config for pyembed '--cflags --libs --ldflags' flags : yes
Testing pyembed configuration            : yes
Asking python-config for pyext '--cflags --libs --ldflags' flags : yes
Testing pyext configuration              : yes
Checking for numpy                       : /usr/lib/python3/dist-packages/numpy/__init__.py
Checking for numpy version               : 1.11.0
Checking for numpy include               : ['/usr/lib/python3/dist-packages/numpy/core/include']
Checking for asrun                       : Could not find the python module 'asrun'

"

My attempts stops to this asrun module and my question is, how to add it to compiling process.

I did compiling from extracted Aster package, and it was succesfull with 13.6 version, but now it doesn't work
Command which I used to configure waf:
./waf configure --enable-mpi --enable-openmp --enable-med --enable-hdf5 --
enable-mumps --embed-mumps --enable-petsc --embed-petsc --use-config=iva --maths-libs=auto  --enable-metis --embed-metis --prefix=$ASTER_ROOT/PAR14.4 --use-config-dir=/$ASTER_ROOT/14.4/share/aster

I have attached also log file. I hope, that somebody can help in this matter.

BR
Ilkka

Adding to console before configuring following:
"
export PYTHONPATH=/$ASTER_ROOT/lib/python3.5/site-packages/:$PYTHONPATH
"
solve the problem.

BR
Ilkka

Last edited by IV_CoAs (2019-10-07 12:50:55)


Attachments:
parallel_error.log, Size: 126.51 KiB, Downloads: 114

Offline

#2 2020-09-16 12:28:23

sameer21101970
Member
Registered: 2019-09-06
Posts: 199

Re: [SOLVED] Aster 14.4 Parallel compiling

Hello Ikka


hello, hope you can guide me in parallel version
a. first problem was hypre was removed from github extension. Did you faced Similar problem in 2019..how you solved it.

''''
****                            Please register to use hypre at computation.llnl.gov/casc/linear_solvers/sls_hypre.html                               **************************************************************************************************                            ===============================================================================                                                     Trying to download git:// github.com/LLNL/hypre for HYPRE         

github.com/LLNL/hypre/archive/v2.14.0.tar.gz is not a tarball

github has removed above link

where to download hypre manually and rerun terminal command""""

kindly reply.

b. I manually download Hypre and configure it.

c. I have similar problem asrun
Checking for numpy version               : 1.19.2
Checking for numpy include               : ['/home/sameer/.local/lib/python3.6/site-packages/numpy/core/include']
Checking for asrun                       : Could not find the python module 'asrun'
(complete log in /home/sameer/Install_Files/aster-full-src-14.4.0/SRC/aster-14.4.0/build/std/config.log)

hope you can show me some idea to solve above.

Offline