Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2020-07-31 13:14:29

vortexe313
Member
Registered: 2020-02-13
Posts: 23

Strange error

Hello,
I'm getting the following error. It appears when I try to define the following contact:


contact = DEFI_CONTACT(MODELE=model,
                         FORMULATION='CONTINUE',
                         FROTTEMENT='SANS',
                         LISSAGE='OUI',
                         STOP_INTERP='NON',
                         VERI_NORM='OUI',
                         ALGO_RESO_GEOM='POINT_FIXE',
                         REAC_GEOM='AUTOMATIQUE',
                         ITER_GEOM_MAXI=10,
                         RESI_GEOM=1.E-2,
                         ALGO_RESO_CONT='POINT_FIXE',
                         ITER_CONT_MAXI=30,
                         ITER_CONT_TYPE='MAXI',
                         RESI_CONT=-1,
                         ZONE=_F(COEF_CONT=100.0,
                                 ADAPTATION='CYCLAGE',
                                 APPARIEMENT='MAIT_ESCL',
                                 GROUP_MA_MAIT='volume',
                                 GROUP_MA_ESCL='Pressione',
                                 NORMALE='MAIT',
                                 VECT_MAIT='AUTO',
                                 VECT_ESCL='AUTO',
                                 TYPE_PROJECTION='ORTHOGONALE',
                                 DIST_APPA=-1.0,
                                 TOLE_PROJ_EXT=0.5,
                                 DIST_POUTRE='NON',
                                 DIST_COQUE='NON',
                                 INTEGRATION='AUTO',
                                 RESOLUTION='OUI',
                                 CONTACT_INIT='INTERPENETRE',
                                 GLISSIERE='NON',
                                 ALGO_CONT='STANDARD',),
                         )
And the error is:


<EXCEPTION> <DVP_1>                                                                                                                  !
   !                                                                                                                                      !
   ! Program error.                                                                                                                       !
   !                                                                                                                                      !
   ! Condition not met:                                                                                                                   !
   !     .false.                                                                                                                          !
   ! File                                                                                                                                 !
   ! /home/A21173/smeca/yamm_build/V2019.0.3_pub_build/V2019_universal/tools/src/Code_aster_stable-v144_smeca/bibfor/algorith/mmelty.F90, !
   ! line 109                                                                                                                             !
   !                                                                                                                                      !
   !                                                                                                                                      !
   !                                                                                                                                      !
   ! Il y a probablement une erreur dans la programmation.                                                                                !
   ! Veuillez contacter votre assistance technique.



Thank you very much for the help.

Offline

#2 2020-07-31 14:11:40

sameer21101970
Member
Registered: 2019-09-06
Posts: 197

Re: Strange error

GROUP_MA_MAIT='volume',
                                 GROUP_MA_ESCL='Pressione',

2D surface has to be in contact & not volumes or volume & surface

Offline

#3 2020-08-01 10:42:31

vortexe313
Member
Registered: 2020-02-13
Posts: 23

Re: Strange error

Thank you very much.

Now I get the following error. The system is the following:
Have a torus around a cylinder, and want to apply a pressure on the torus surface in order to "indent" the cylinder. But I define as a 2D object the torus surface in order to apply  DKT model.

I apply the pressure through
load_tr = AFFE_CHAR_MECA(
  MODELE=model,
  PRES_REP=_F(
    GROUP_MA=('Pressione', ),
    PRES=1.0
  )
)

is it possible that PRES_REP is no good for shells?

<S> Exception user raised but not interceptee.                                 !
   ! The bases are fermees.                                                         !
   ! Type of the exception: error                                                   !
   !                                                                                !
   ! Erreur :                                                                       !
   !   Le TYPE_ELEMENT MEDKQU4 devrait calculer l'option :  RIGI_MECA_PRSU_R,       !
   !   mais il ne le fait pas encore (la programmation est manquante).              !
   !   Le calcul n'est possible que dans les cas "triviaux" : chargement nul, ...   !
   !                                                                                !
   ! -> Risques & Conseils :                                                        !
   !    * Si ce manque dans la programmation vous semble important, il faut émettre !
   !      une demande d'évolution.                                                  !

Thank you very much for the help.

Offline

#4 2020-08-12 00:02:26

AsterO'dactyle
Administrator
Registered: 2007-11-29
Posts: 342

Re: Strange error

Hello,

PRES_REP is OK for DKT but not with option "'SUIV'" in STAT_NON_LINE


Code_Asterの開発者

Offline