Welcome to the forums. Please post in English or French.

You are not logged in.

#1 2010-02-01 14:27:48

JMB365
Member
Registered: 2008-01-19
Posts: 778

[SOLVED] ASTK Ver:1.8.0 2048 MB limit in 64bit Ubuntu

Hello All,

This is for the benefit of others (and MY memory limits).  An ASTK job is started with memory set to be 4000MB, but it reports that memory can only be 2048MB!  Compiling it on a 64bit OS would allow one to use more than the 2048MB limit set by a 32bit OS.  The PC has 8GB (or more) of RAM and a lot more as swap set aside.

Edit the config file in /opt/aster/etc/codeaster/asrun (/opt/aster/ASTK/ASTK_SERV/config in Ver 9 or older).  There is a memory limit variable that needs to be modified to 4096 (or higher as one chooses):

sudo cp /opt/aster/etc/codeaster/asrun /opt/aster/etc/codeaster/asrun.saved
sudo gedit /opt/aster/etc/codeaster/asrun &

Change the value for memory limit as shown below:

interactif_memmax : 4096

JMB


STA10.3/NEW11 Ubuntu 64 bit on multiple PCs

Offline

#2 2010-02-01 20:52:51

keeswouters
Member
From: kuringen
Registered: 2007-12-01
Posts: 144
Website

Re: [SOLVED] ASTK Ver:1.8.0 2048 MB limit in 64bit Ubuntu

Hoi JMB

thank you for this information.
Just to add, you have to update the server settings in ASTK (Configuration --> servers --> refresh now) after this, at least in my configuration.

kind regards  - kees


kind regards - kees
--
I a parallel univers the laws of mechanics may be different.

Offline