Welcome to the forums. Please post in English or French.

You are not logged in.

#26 2020-03-14 14:24:44

hberro
Member
From: Palaiseau, France
Registered: 2011-07-05
Posts: 36

Re: Salome_Meca V2019.0.3_Ubuntu 18.04 Installation Issues

So nothing actually changed... Did you try to reboot to get the changes applied ?

Offline

#27 2020-03-14 16:40:43

sameer21101970
Member
Registered: 2019-09-06
Posts: 246

Re: Salome_Meca V2019.0.3_Ubuntu 18.04 Installation Issues

Yes Re-Boot Done, same error message.

Offline

#28 2020-03-14 17:24:02

hberro
Member
From: Palaiseau, France
Registered: 2011-07-05
Posts: 36

Re: Salome_Meca V2019.0.3_Ubuntu 18.04 Installation Issues

I'm out of solutions, there is really something not right with the your opengl and mesa libraries.

The only thing I can recommend to make salome work (with software rendering) is to follow page 2 of the recommended installation procedure (follow the steps as if you were in a virtual machine), this will override the mesa libs with ones compiled specifically for salome.

You won't get 100% of your GPU capacity, but it should still be ok for limited size models (~100k elements is ok).

Good luck

Last edited by hberro (2020-03-14 17:24:36)

Offline

#29 2020-03-16 13:16:26

sameer21101970
Member
Registered: 2019-09-06
Posts: 246

Re: Salome_Meca V2019.0.3_Ubuntu 18.04 Installation Issues

would you give your graphic driver detail...it is intel i965, G series or other

Offline

#30 2020-03-16 13:17:58

sameer21101970
Member
Registered: 2019-09-06
Posts: 246

Re: Salome_Meca V2019.0.3_Ubuntu 18.04 Installation Issues

mesa upgrades specific drives only...please reply.

the base of SEG problem seems to be graphic drive

Offline

#31 2020-03-16 13:25:24

sameer21101970
Member
Registered: 2019-09-06
Posts: 246

Re: Salome_Meca V2019.0.3_Ubuntu 18.04 Installation Issues

httpsdoubledot//mesamatrix.net/

has the list

Offline

#32 2020-03-16 14:45:53

hberro
Member
From: Palaiseau, France
Registered: 2011-07-05
Posts: 36

Re: Salome_Meca V2019.0.3_Ubuntu 18.04 Installation Issues

Did you try the procedure of page #2 ?

code-aster.org/spip.php?article1112

This installs a specific mesa version that should make salome meca work without hardware acceleration.

Offline

#33 2020-03-17 10:53:44

sameer21101970
Member
Registered: 2019-09-06
Posts: 246

Re: Salome_Meca V2019.0.3_Ubuntu 18.04 Installation Issues

AS procedure set on page 2, it is working.
Thanks.
Code_Aster has all options to save money on Hardware.
My Old PC Spec. Dual Core, Intel G33 Chipset, 4GB Ram...S Meca 2019 Working without SEG Error.

SOLVED

Offline

#34 2020-03-17 11:03:55

hberro
Member
From: Palaiseau, France
Registered: 2011-07-05
Posts: 36

Re: Salome_Meca V2019.0.3_Ubuntu 18.04 Installation Issues

Excellent ! Good to know you got salome_meca working !

Offline

#35 2020-08-24 11:24:10

Kidbooo
Member
Registered: 2019-03-28
Posts: 5

Re: Salome_Meca V2019.0.3_Ubuntu 18.04 Installation Issues

The following worked on our machines - and (cross my fingers) this seems like a very stable SMECA.  Doing a simple case I was able to generate a simple geometry, add groups, mesh it, add the mesh groups, move into ASTER Study, use the Assistant, run the case, then PostProcess and then I went back to Geom, Smesh, Shaper - then back to AsterStudy, then back to PostProcess - all without crashing (I have never been able to do this before without a crash).

Offline

#36 2020-09-24 18:12:28

amvali
Member
Registered: 2020-09-17
Posts: 6

Re: Salome_Meca V2019.0.3_Ubuntu 18.04 Installation Issues

Hi there,

I install Salome-Meca, but when I launch it, it gives the following error:

aliagha@aliagha-VirtualBox:~/salome_meca/appli_V2018.0.1_public$ ./salome
runSalome running on aliagha-VirtualBox
Error when trying to access active network connections.
Traceback (most recent call last):
  File "/home/aliagha/salome_meca/appli_V2018.0.1_public/bin/salome/PortManager.py", line 111, in __isNetworkConnectionActiveOnPort
    p = Popen(cmd, stdout=PIPE, stderr=STDOUT)
  File "/home/aliagha/salome_meca/V2018.0.1_public/prerequisites/Python-2710/lib/python2.7/subprocess.py", line 710, in __init__
    errread, errwrite)
  File "/home/aliagha/salome_meca/V2018.0.1_public/prerequisites/Python-2710/lib/python2.7/subprocess.py", line 1335, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
Searching for a free port for naming service: 2813 - OK
Searching Naming Service + found in 0.1 seconds
Searching /Kernel/Session in Naming Service +++++Gtk-Message: 10:03:11.778: Failed to load module "canberra-gtk-module"
+libGL error: MESA-LOADER: failed to open swrast (search paths /usr/lib/x86_64-linux-gnu/dri:\$${ORIGIN}/dri:/usr/lib/dri)
libGL error: failed to load driver: swrast
Warning: this type (SALOME_MED/MEDCouplingFieldDoubleCorbaInterface,objref) already exists, it will be ignored.
++Traceback (most recent call last):
  File "/home/aliagha/salome_meca/appli_V2018.0.1_public/bin/salome/runSalome.py", line 633, in useSalome
    clt = startSalome(args, modules_list, modules_root_dir)
  File "/home/aliagha/salome_meca/appli_V2018.0.1_public/bin/salome/runSalome.py", line 578, in startSalome
    session=clt.waitNSPID("/Kernel/Session",mySessionServ.PID,SALOME.Session)
  File "/home/aliagha/salome_meca/V2018.0.1_public/modules/KERNEL_V8_5_0/bin/salome/orbmodule.py", line 174, in waitNSPID
    raise RuntimeError, "Process %d for %s not found" % (thePID,theName)
RuntimeError: Process 3593 for /Kernel/Session not found


--- Error during Salome launch ---
aliagha@aliagha-VirtualBox:~/salome_meca/appli_V2018.0.1_public$

Would you please help me?

Thanks,
Ali

Offline

#37 2020-09-24 23:17:47

sb1966
Member
Registered: 2015-03-16
Posts: 179

Re: Salome_Meca V2019.0.3_Ubuntu 18.04 Installation Issues

Hi,
It seems you have not installed some prerequisite, may be the net-tools. Please install all the prerequisites carefully and try a fresh install of Salome-Meca.
Hope this helps.

Best wishes

Sukumar

Online