enfr

salome_meca 2019 sous licence LGPL disponible au téléchargement

25 septembre 2019

La nouvelle version sous licence LGPL de la plate-forme salome_meca 2018 est disponible au téléchargement.

salome_meca 2018 intègre les produits suivants :

  • SALOME 9.3.0 ;
  • code_aster stable (version 14.4) ;
  • AsterStudy ;
  • Salome-Meca plugins : CABRI ;
  • code_aster translator ;
  • astk.

Installation

  • Décompresser l’archive et lancer l’installation :
tar xzf salome_meca-2019.0.1-1-LGPL.tgz && ./salome_meca-2019.0.1-1-LGPL.run

Cet installeur installe salome_meca dans le répertoire de votre choix (attention, le chemin du répertoire ne doit pas présenter d’accents) et crée automatiquement un raccourci sur le bureau à partir duquel vous pourrez démarrer salome_meca.

  • Lancer salome_meca 2019 :
cd appli_V2019_univ
./salome

Nouveautés

Cette version intègre la nouvelle version de l’interface de code_aster, AsterStudy 2019.0.1. Cette nouvelle version du module est une évolution majeure de la version 2018.0.1, les principales nouveautés sont :

  • onglet Results pour visualiser rapidement les résultats ;
  • un résumé graphique d’une analyse ;
  • lien avec Openturns permettant de définir une étude "paramétrique" et de l’exporter dans Openturns ;
  • de nouveau assistants de calcul pour une mise en données rapide ;
  • possibilité de poursuivre avec une étape graphique après une étape texte (ajout d’un éditeur de concept en mode texte) ;
  • lancement sur serveur pré-configuré et totalement opérationnel ;
  • support des bases distantes.

Distributions Linux supportées

Cette version a été testée avec les distributions Linux 64bits suivantes :

  • Ubuntu 16.04 ;
  • Debian 8 et 9.

Les versions suivantes sont supportées moyennant l’installation de prérequis supplémentaires (cf. section dédiée) :

  • Ubuntu 18.04 et plus ;
  • Redhat 7 et dérivées (CentOS, Scientific Linux).

Instructions pour installer les prérequis nécessaires aux distributions anciennes

Ubuntu 18.04 et plus

La bibliothèque ’libstdc++.*’ installée par salome_meca entre en conflit avec celle du système.

cd $HOME/salome_meca/V2019_univ/prerequisites/debianForSalome/lib
rm libstdc++.so.6.0.20
ln -s /usr/lib/x86_64-linux-gnu/libstdc++.so.6 libstdc++.so.6.0.20

Installer les paquets suivants :
libQt5OpenGL
libQt5Concurrent
libNLopt0
libQT5MultimediaWidgets (pour shaper)

Redhat 7 et dérivées (CentOS, Scientific Linux)

Télécharger les sources de gcc-4.9.2 et le compiler :

yum install libmpc-devel mpfr-devel gmp-devel
tar xvfj gcc-4.9.2.tar.bz2
cd gcc-4.9.2
./configure --disable-multilib --enable-languages=c,c++
make -j 4
make install

Installer salome_meca 2019.

Faire un lien dans l’installation :

cd $HOME/salome_meca/V2019_univ/prerequisites/debianForSalome/lib
rm libstdc++.so.6.0.20
ln -s /usr/local/lib64/libstdc++.so.6 libstdc++.so.6.0.20